Jump to content
wasted talent

wrx knock settings

Recommended Posts

Hi all,

V1/2 g4+ plugin ecu, 05 wrx knock sensor in standard location, ej257 with v3 heads. Engine only has 1500km on it.

I'm constantly seeing knock from idle to redline regardless of load or timing.

only way to get a zero knock reading at idle and any rpm is to turn off cyl 1 sensing while leaving 2, 3 and 4 active.

what can cause this to occur?

will upload a pcl file later today

edit: attached most recent .pcl i have access to currently. all knock settings should still be the same iirc

 

current 2-4.pclr

Edited by wasted talent
added .pcl

Share this post


Link to post
Share on other sites

The gain channel is set much higher than I normally see, more typically it is 1 or 2.  Usually I would set this so you have an average knock level of about 100 reported at medium speed/load.  I would also set the start window higher - about 15deg. 

Not releavant yet but will be when tuning:  Your target table needs the Y axis changed to "MAP", it is currently set to "AN1 - MAP Sensor" which is raw voltage rather than pressure.  Clear I-trim tables should be set to ECU power on.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...