Jump to content
Grant Baker

RPM Limit stopped working

Recommended Posts

Hi

Got an EVO here with a ViPeC plug in (V series).

All was fine and then suddenly on an acceleration ramp test, the rev limit did not activate, and hasn't activated since!

Nothing was changed in the tune except some minor fuel tweaks!

Any ideas?

PCL Attached. Please note it is not finished...

AlisonE4wORK.pcl

Share this post


Link to post
Share on other sites

In the V series and old G4 ecu's a fuel cut limiter wont work if your injector duty cycle is above 100%.  So you either need to fix the fuel system or change to ignition cut.

Share this post


Link to post
Share on other sites

That makes perfect sense now. 

Bit weird that it allows you to over rev despite injector DC being over 100% though!!

I assume this is not something that will be fixed and updated?

Share this post


Link to post
Share on other sites

Development on the V series stopped somewhere around 2013.  This bug was discovered sometime after that.  It was fixed in G4+ but is something you will have to live with in the V series.  I would not be running any car/ecu with inj DC above 90% having said that.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...