Jump to content
cj.surr

Cam Position Parameter Lag

Recommended Posts

I am having an issue tuning fueling because the parameter that references cam position lags over a second behind the actual cam position reading. It is also coarse and updated slowly. See the image below comparing the two cam position parameters (they are inverted because the "inlet/ lh posn" is absolute. 

"Cam angle #1" is much more precise but it cannot be used as a table axis. I need this because the Vanos on my S52 engine takes a full second to engage, and it can affect VE as much as 20%+. So I have a 4D fuel table that looks at cam angle to account for the transition time of the mechanical VVT. There is no way the "inlet/lh pos" parameter can work for this.... It's even slower than the mechanical unit itself. Can the "inlet/lh pos" parameter be changed so it does not have a delay and is more precise? It seems fairly useless this way.

676904833_campositionlog.thumb.png.29016191d25f78e5f1d262625caabe8c.png

Thanks

Log 2019-07-13 1;32;51 pm CAM POS TEST.llg

Share this post


Link to post
Share on other sites
3 hours ago, Adamw said:

Are you using M52 trigger mode?  Try changing VVT PID to custom, then in the Inlet LH settings, set the filtering to 1.

The Main trigger mode is generic 60-2

VVT was previously off (as recommended in my other thread). I turned it on to change filtering to 1 (from 4) and it has solved the delay problem but not the update frequency problem. Please see screenshot below.

It's a PC Log, main rate is set to 20hz. Also I think you can tell from the steps that it isn't a log rate issue, but a parameter update issue.

image.thumb.png.7184997a5b68ff17434c7fa895b422b2.png

Share this post


Link to post
Share on other sites

I think the problem probably is you due to not using a compatible trigger & VVT mode.  Your Inlet LH error counter is continuously counting up and the Inlet LH signal is reporting extra pulses.  Try setting trigger mode to M52 VVT and VVT mode to M52, this should work with the single tooth cam and 60-2 crank. Trigger offset and VVT offset may need to be set again with this change.  If that doesnt help please post another log and the tune file.

 

On 7/14/2019 at 5:37 AM, cj.surr said:

I need this because the Vanos on my S52 engine takes a full second to engage, and it can affect VE as much as 20%+.

I suspect something is also mechanically wrong if this is the case, in my experience the 2 state vanos is usually near instant switching (less than 50ms at a guess), you dont normally need to consider cam position at all, usually just switch VE tables at the same time the vanos is activated. 

Share this post


Link to post
Share on other sites
6 hours ago, Adamw said:

I think the problem probably is you due to not using a compatible trigger & VVT mode.  Your Inlet LH error counter is continuously counting up and the Inlet LH signal is reporting extra pulses.  Try setting trigger mode to M52 VVT and VVT mode to M52, this should work with the single tooth cam and 60-2 crank. Trigger offset and VVT offset may need to be set again with this change.  If that doesnt help please post another log and the tune file.

Ok, thank you. I will try this later. I am confused why I need to use VVT settings at all, I have been told by Simon that I should not be using VVT settings with a simple on/off VVT. 

Quote

 

I suspect something is also mechanically wrong if this is the case, in my experience the 2 state vanos is usually near instant switching (less than 50ms at a guess), you dont normally need to consider cam position at all, usually just switch VE tables at the same time the vanos is activated. 

Are you sure? I know that if you test it during assembly with compressed air, it actuates about that fast. But I am looking at log files from 3 different M5x-based engines and they all take about a full second to fully engage. I know at least one of those (mine) has fresh vanos seals, I would assume the other two cars do as well. 

I now see that it's possible to interpolate between two VE tables based on cam, which I am excited to try. I think that will work very well if we can sort out the cam signal. 

 

Share this post


Link to post
Share on other sites
On 7/15/2019 at 3:14 AM, Adamw said:

I think the problem probably is you due to not using a compatible trigger & VVT mode.  Your Inlet LH error counter is continuously counting up and the Inlet LH signal is reporting extra pulses.  Try setting trigger mode to M52 VVT and VVT mode to M52, this should work with the single tooth cam and 60-2 crank. Trigger offset and VVT offset may need to be set again with this change.  If that doesnt help please post another log and the tune file.

This fixed it! Inlet/lh position is now pretty much perfect. I get about 7-8 errors on startup but nothing after that. (usually a couple missing teeth and then some "6th" and "8th" pulse erorrs - whatever that means). I attached a log, it doesn't seem like there are any problems. 

image.thumb.png.fd1822a71465246a6ed313ecbb4a6e8d.png


My main question from the other thread still remains, though. How do I know if the engine has fallen back on batch fire/wasted spark (if it can at all)? Or do I assume that an "OK" inlet/lh signal means the engine is sync'd?

Log 2019-07-15 11;18;53 pm vvt test success.llg

Share this post


Link to post
Share on other sites
4 hours ago, cj.surr said:

How do I know if the engine has fallen back on batch fire/wasted spark

It doesnt do this. If you have configured spark as "direct", its always direct.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...