Jump to content
Sparkystav

Cruise Control PID

Recommended Posts

I have a Thunder that runs my Porsche Electronic throttle. I originally had the throttle on my 2L 6 cylinder turbo, but have now transferred it to the 4L V8 Twin turbo i have built a custom inlet for. The throttle works as it should for normal driving, but if i activate cruise the car seems to constantly speed up and slow down every second or so.

I have used the same PID settings for cruise control from my old, but im assuming its them that are causing this? Im not an expert in this area so can anyone suggest what i need to adjust to try to stop it?

 

Current settings are::

P - 2.00

I - 0.0312

D - 1.00

 

thanks

Share this post


Link to post
Share on other sites

grab a log while this is happening and check for the following to determine if its a problem with the throttle body control, or further up the stack.

TP target %

vehicle speed (may be LR wheel speed or similar)

TP main %

MAP

If TP target % is moving up and down in time with the behaviour you are describing, then the ECU is changing what its actually requesting and the problem is further up. If TP target is constant, but TP main % jumps around in time with your problem then its a PID control issue.

Also, make sure MAP & vss show some kind of change to match the feeling you describe. If the ECU isnt showing speed changes or load(MAP) changes, at all, then it might be something outside of the ECU entirely (abs, alignment, tyres, etc)

Share this post


Link to post
Share on other sites

Had a look at a log, and the ethrottle target is moving so it unlikely to be the PID as you say. 
There is speed changes going on, so I’m wondering if that is a result of the variance in the Throttle, or maybe is the cause. Would adding extra slip filter to the speed source help?

Share this post


Link to post
Share on other sites

Having re-read your original post I think i got slightly mixed up by your mention of ethrottle TB swaps & PID. 

There are 2x set of PID's relevant here, 1 in the Ethrottle config itself, which is what I suggested you test, and it seems to be fine. This is used to translate TP target into TP motor voltages to move the throttle plate

The second completely independent PID's are for the cruise control system itself - ie these are the settings the ECU uses to determine what TP target should be in order to add/remove 5kph or whatever it needs to hit speed target. The numbers you posted look like the cruise control PID's, and so you should change those to fix constant speedup/slowdown. Technically this would be considered "overshoot" on the PID algorithm, and you can either reduce I or increase D to stop this happening. Small changes at a time are a good idea.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...