Jump to content
Kimple Fi

Can Lampda problem

Recommended Posts

Hello everyone !

We load newest software and put ecu latest firmware. Connection ecu and laptop Works fine. When you assembly can-lambda, then connection lost. Have any same problem?

Share this post


Link to post
Share on other sites

I'm guessing you have a wire in ECU of some sort and are using the can plug on the case. Have you stripped out the other serial wires in the CAN plug?  If they're left in place you'll lose your pclink connection when the CAN lambda is plugged in

Share this post


Link to post
Share on other sites

As per JMP's suggestion, some ECUs also have serial comms pins in the same 6 pin comms connetor.  So if you use the old CANDASH (not recommended) cable which had serial wires connected inside it will interrupt PC comms.  Follow the CAN wiring instructions in the CAN Lambda manual and it will work as expected.

Share this post


Link to post
Share on other sites

Hello

This how i wiring my can lampda . 

Is that ok !?

I think I've made connections correctly in accordance with the instructions.  Can lampda was fully functional before I upgraded to ECU.

IMG_20190819_183828.jpg

Screenshot_20190819-183919.png

Screenshot_20190819-185321.png

IMG_20190819_230100.jpg

Share this post


Link to post
Share on other sites

The 5 wire cable is the problem, this means the serial pins are connected, it should only have 2 pins (CAN H/CAN L) connected.

The easiest fix would be to either cut the grey and yellow wires near the ecu or pull the terminals out of the plug.

tJ3quAT.png

Share this post


Link to post
Share on other sites

Hi!  Now I have severed wires.  Now my computer will stay connected to the ECU :).  But i dont stay in ecu can lampda settings!?.  I can do them on a computer and send them to the ECU, but when I contact the ECU later, the settings have uninstalled can lampda.  What am I doing wrong !?

IMG_20190821_185405.jpg

Share this post


Link to post
Share on other sites

What you will have is old firmware in the ECU. Upgrade the ECU firmware and you will then have the CAN lambda as an option in the CAN settings.

 

 

Share this post


Link to post
Share on other sites
14 hours ago, Kimple Fi said:

I can't start the engine now because the cylinder head is in the machining center.

Im not sure how you have been testing it, but be aware the CAN Lambda wont work until the engine is running.  It wont even start heating until it gets an RPM signal from the ECU.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...