Jump to content
Armand

Rb20 cas

Recommended Posts

Hi guys. My first post on here so bare with me.

Did some searching and could not find exactly what im looking for.

So im in the process of wiring in my g4+ onto a series 1 rb25det. 

So problem no1 : not 100% sure if the pin outs are the same on the rb20 type A cas vs rb25/26 non neo.

Problem no2 : the signal wires that run from the ecu to the cas is a 8v source,not too sure if the cas needs 8v or 12v signal to the cas.

Some info would be great if possible.

Thanx.

Share this post


Link to post
Share on other sites

If your cas is the aluminium body mitsubishi unit then your pinout will be as below.  Only the Hitachi one that has a black plastic cover from the Neo engine is different.

They are meant to be powered by 12V, 8V will probably work but I have never tried.

L08t5DA.png

Share this post


Link to post
Share on other sites

Thanx Adam it is the mitsubishi one.

For my next noob question..

Am I corect in saying the cas has two triggers. One for the 1' and one for the 120'. So essentialy these two triggers should be able to run direct spark? 

I have changed the cas trigger plate from oem to the aem unit for better results or at least less hassles later on. 

I know some guys preffer wasted spark but i do have enough ignition outputs.

Thanx.

Share this post


Link to post
Share on other sites

Just to add onto my question about the wiring. Would it make a difference on the trigger wires if i change the disc to a aem 24+1? Im getting no rpm or trigger signals. 

Share this post


Link to post
Share on other sites
3 hours ago, Armand said:

Just to add onto my question about the wiring. Would it make a difference on the trigger wires if i change the disc to a aem 24+1? Im getting no rpm or trigger signals. 

No the wiring wont change, you will have to change the trigger settings to match though.

Share this post


Link to post
Share on other sites

This is what i used to set it up as.

On 11/20/2016 at 8:55 AM, milton r33 said:

Hi is the rb26 cas meant to be set to relutor or optical hall ? I have the AEM 24 TOOTH cas disk

i have the engine to top dead centre 

I have set the trigger setup to multitooth 

Trigger priority to trigger 1 

in trigger 1 its optical hall ,multitooth position set to cam and tooth count 24  tooth

trigger 2  optical hall sync mode to  cam pulse X1 is this all correct ? 

Still nothing.

Share this post


Link to post
Share on other sites

so after some reading up and adjusting setting I got trigger1 and 2 on yes but no sync.

so plugged everything in and no joy, only a promise followed with some backfires.

I have no idea if the timing setting are correct for the current setup.

hope the attached file gives some insight.

thanx Adam.

armand setup map 1.pcl

Share this post


Link to post
Share on other sites

When cranking do you see an RPM? 

The ECCS sync will no longer be applicable as the trigger mode is nolonger Nissan 360. 

If you have an RPM reading during crank then you will need to check and adjust the base timing as this could be way off with the changed trigger disk.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...