Jump to content
Hu5tlermr2

AW11 MR2 with a Gen4 3sgte

Recommended Posts

I am currently trying to sort my mr2, I am running the Link Atom, my problem is that my harness has a 3 pin TPS but my aftermarket throttle body and intake manifold has a 4 pin TPS from a Supra Part Number 89452-22080 I currently have it wired in with 3 wires (IDL not connected) the car cranks and starts but dies immediately, I have calibrated the TPS but still wont idle on its own, do I have to change a setting on the ECU? Or do I have to wire in the 4th wire (IDL). It's also worth saying that i am not running the OEM 3sgte Iddle air valve (not plugged in). When i do the TPS adjustment it adjust fine, but doesn't want to stay on.

Share this post


Link to post
Share on other sites

Why do you think it is related to TPS?  Does the TP parameter work when you press the throttle or not?

Have you checked base timing and adjusted the master fuel?

 

Share this post


Link to post
Share on other sites
11 minutes ago, Adamw said:

Why do you think it is related to TPS?  Does the TP parameter work when you press the throttle or not?

Have you checked base timing and adjusted the master fuel?

 

Yes i believe it does work, because when i press the accelerator it goes up, and down. adjusted master fuel? Also timing is good. also thought it was tps since i am confused with the 4th wire not being used since its the iddle wire, also because i am not running an IACV.

 

 

Share this post


Link to post
Share on other sites

confirm that your fuel pump remains running and fuel pressure is good.  If you dont have the fuel trigger to the circuit opening relay connected/configured correctly the car will run for a few seconds on the initial burst of fuel the circuit opening relay provides before it shuts the pump off due to no trigger to the FC pin.

When fuel pressure is confirmed, adjust the "Master Fuel" figure in "Fuel Main" configuration up until the engine stays running and your wideband reads a sensible number.
image.png.84e49c570ef7609e57926d7dd25661b9.png

Share this post


Link to post
Share on other sites
22 minutes ago, JMP said:

confirm that your fuel pump remains running and fuel pressure is good.  If you dont have the fuel trigger to the circuit opening relay connected/configured correctly the car will run for a few seconds on the initial burst of fuel the circuit opening relay provides before it shuts the pump off due to no trigger to the FC pin.

When fuel pressure is confirmed, adjust the "Master Fuel" figure in "Fuel Main" configuration up until the engine stays running and your wideband reads a sensible number.
image.png.84e49c570ef7609e57926d7dd25661b9.png

thank you I will check tomorrow morning, my car is really loud when it starts, so don't want to upset the neighbors

 

Share this post


Link to post
Share on other sites
On 10/25/2019 at 10:39 PM, JMP said:

confirm that your fuel pump remains running and fuel pressure is good.  If you dont have the fuel trigger to the circuit opening relay connected/configured correctly the car will run for a few seconds on the initial burst of fuel the circuit opening relay provides before it shuts the pump off due to no trigger to the FC pin.

When fuel pressure is confirmed, adjust the "Master Fuel" figure in "Fuel Main" configuration up until the engine stays running and your wideband reads a sensible number.
image.png.84e49c570ef7609e57926d7dd25661b9.png

thank you I will check tomorrow morning, my car is really loud when it starts, so don't want to upset the neighbors

Thank you all that helped out, I went ahead and rechecked everything, it ended up being the FPR, the Return was connected on the In side of the regulator, corrected, adjusted, and now the car runs fine, I set up iddle with the throttle body iddle screw since i am not running an IACV.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...