Jump to content
Chunky Monkey

Incorrect AIM DASH numbers from ECU

Recommended Posts

Hey team,

I have just installed a AIM 1.2 MXS STRADA with my LINK G4 Storm.

I had some problems with BOTH my OIL pressure and Fuel pressure not displaying correct numbers on the dash.

I discovered that the ECU had both sensors as PSI and apparently it was meant to be in KPA, so i changed both to KPA. Easy as.

Re-flashed DASH and BINGO, OIL pressure in KPA was now reading correct on the AIM DASH, I then changed the OIL pressure to PSI on the dash and BINGO again! easy as.

HOWEVER Fuel pressure did not fix its self. its reading approx at 20KPA (about 250KPA out at idle) Both the LINK ECU and the mechanical gauge are reading correct 275KPA ish  

The only thing i can see that is odd is that in the LINK ECU under analog the word OIL PRESSURE is in a dark yellow and the remaining inputs are written in black. Have i set up the fuel pressure wrong somehow?

IDEAS?

Cheers Team

Share this post


Link to post
Share on other sites

I just loaded your tune into a G4 and connected a CAN sniffer, the ECU is sending the data out correctly as shown below.  

On your facebook post I asked if your dash was on the latest firmware, are you sure it is? AIM made some changes to the oil and fuel press settings about a year ago.  Make sure you are using the latest RS3 and latest firmware, you can check by clicking the cloud icon in RS3.

n8lIKKA.png

Share this post


Link to post
Share on other sites

Good to know that the ECU is correct

I am 99% sure it is all up to date, the company i brought the dash from also loads a basic Link Ecu dash setup (NZEFI)

Could my dash be faulty? I ask as I brought a Solo 2 18 months ago and that had a fault from new.

Thanks for the help mate.

Share this post


Link to post
Share on other sites

I think it is unlikely a fault could make one CAN value read wrong, more likely a firmware/bug/software/scaling issue.

Here is a guide how to do the firmware update:  https://www.aim-sportline.com/download/firmware/rel_histories/MXx_EVOx_Solo2Solo2DL_MyChron5_FirmwareUpdate_101_eng.pdf

Before you do that, check your RS3 version at the top left of your screen as shown below, there was a big update just recently, the current is 3.30.11 or 12.  If yours is older you can update on the same "cloud" page as the firmware.

After updating dash firmware, go to the dash config, ecu stream tab and check the version number after the ECU protocol as below, it should be 2.00.05:

UUhL49m.png

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...