Jump to content

Link fury wideband issue


Recommended Posts

Hello,  

 

im hoping I can get some help regarding this issue we are having,

 

car was getting tuned on Friday, everything going well but we noticed The fury on board wideband Drops out then comes back on again constantly 

 

have a brand new link fury ecu with custom milspec patch harness to suit r32 gtr/rb26, 

wideband wires from ecu go to a Bosch lsu4.9 plug which the o2 sensor plugs into

o2 sensor is a brand new genuine Bosch Motorsport sensor 

 

any ideas As to why it would be dropping in and out ?

 

Link to post
Share on other sites
  • 3 weeks later...
  • 2 weeks later...

Trying to attach log but having issues doing so will try again 

 

but when lambda 1 drops out at around 5000rpm I get “lambda error 2”

 

shows afrs once revs drop again but still shows error 

 

what does “lambda1 error 2” mean, what’s the problem 

Link to post
Share on other sites

Yep your file share works.

This is a weird issue, it appears like the sensor controller resets.  Just as a test can you try temporarily changing the lambda setting "run when stalled" to yes and do another run to see if it still freaks out at high rpm.

Where does the 12V wire to the lambda sensor come from?  Can you try connecting that to somewhere different (even if it is just a temporary alligator clip test lead to battery or something)

Link to post
Share on other sites

Very odd issue 

 

I have my o2 sensor 12v wire going to Fury Plug-A pin 5 (+14v) which it also shares with CAN 12v, electronic throttle relay 12v and obviously the o2 sensor 12v

 

We had my m&w cdi 12v connected to factory harness plug Pin 59 (12v+ power)

but we ditched the cdi as we had issues and now running r35 coils

 

i Now have that old cdi 12v cable spare I can get power from that and test again and get a log 

 

 

 

Link to post
Share on other sites

ok i gave it a new power supply and now the issue is worse

 

check logs just idling afrs work then don't and it keeps doing that, lambda diagnostics shows it operating, then going into diagnostics mode, then heating, then operating etc 

keeps displaying error 2

 

see log

https://drive.google.com/file/d/1oObwtnRGcgfasvI11StI8LSo0XOBBzPH/view?usp=sharing

Link to post
Share on other sites

Sounds like it is possibly a hardware issue.  I suggest you still email tech support for advise before concluding that however, I have no info on what error 2 relates to.  

You've tried another sensor already right?

Link to post
Share on other sites

Yeh but it was a my old sensor from my old setup, I will try a brand new one to make sure 

 

also I tried “run when stalled” to yes and no difference 

 

keep you guys updated with what the final outcome is once it’s fixed 

Link to post
Share on other sites
  • 1 month later...

Hello

 

got an update on this, 

I sent logs to link technical and they agreed my link fury showing “lambda error2” needs to go back for repairs.

 

while it was getting repaired, my mate had a link fury ecu I could borrow, loaded my map and afrs still dropped out on boost/high rpm, but it didn’t drop out while cruising or at idle like mine did

 

i got my ecu back on Friday from link and tried it today, still drops out at idle randomly, and at high rpm and shows “lambda error2” again

 

so both ecus are doing the same thing, my friends one though won’t drop afrs at idle or cruising like my original one does

 

before I sent the ecu to link I have tried different power source for the lsu4.9 sensor

and 2 different sensors 

 

does anyone know what this could be ?

 

im about to forget about it all and run an aftermarket digital wideband controller and be done 

Link to post
Share on other sites

I'd look into grounding.

You mentioned a custom Mil-spec harness. 

Hopefully you get a diagram so you can verify where the grounds go and if they are clean. 

Dont forget about the sensor grounds as well.. As far as I know they are not supposed to be grounded. 

 

You could run a voltage drop test to check or just run new separate grounds and see if anything changes. 

Could also be a nicked wire..

Link to post
Share on other sites

The o2 sensor is wired directly to ecu and I don’t have any other sensor issues only with onboard wideband controller 


all the earths from engine wiring harness mount to a bolt at the back of head on the engine, and also my ignition coils (r35 gtr coil kit) earth at the same point, could this be an issue sharing an earth point with ignition ?

funny that one ecu drops out at idle and cruise and the other doesn’t 

but both do at high rpm ?!

Link to post
Share on other sites

5A8C9561-A42D-48AE-966A-D7AB79CED4E1.jpeg
 

abit hard to read as I had to upload it small 

“lambda error 2” according to lambda sensor control error values still showing it’s an “internal control issue and no user actions can be taken to correct”

Link to post
Share on other sites

Error 2 I believe is something to do with an SPI bus timing error.  According to engineering the two most likely possibilities to cause this are an internal hardware issue or extreme EMI noise.  I think you have ruled out a hardware issue so I would be leaning more towards a noise issue.  Do your mates Fury work ok on his car or is it not fitted to a car?  

Can you try turning ECU logging off as a test - I believe ecu logging can put a lot of traffic on the SPI bus in some cases.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...