Jump to content
paulr33

EVO 8 V44 plugin - no knock or speed input?

Recommended Posts

thanks another crazy tuning question theory sorry, the turbo im about to fit, HKS recommend to not exceeed 900deg EGT. I have an EGT controller to wire into An Volt 1 and ill configure An Volt 1 as EGT 0-5v.

i was thinking of using 4d fuel and 4d IGN map to deal with timing and fuel adjustments if EGT is over 900deg but was wondering if theres a way to do fuel cut - like when i get map limit exceeded, but via an EGT value?

otherwise, if i go via the 4d map functions - can you see any issues with this approach

 

Share this post


Link to post
Share on other sites

hi all

i never got around to making my knock box work as the last issue i had was the AUX window wasnt wired into the vipec.

recently had some work done and i got my workshop to wire in the AUX window to the vipec from the knock block.

i still dont get any knock values whatsoever and the logs show no knock values or counts even when the knockblock is in test mode. the knockblock manual says it should flash when in test mode, but mine doesnt flash, the blue light remains constant. even if i have it in "test mode" - both dials on F and F and turning the unit on and off i never see any status change or values on the vipec logs or display for knock. logging with test mode yields no knock values either.

 

am i doing something wrong or expecting something i shouldnt be? at a dead loss here sorry

im certain its configured correctly and wired in properly, normally i have it on 2 and C.

 

keen to hear if anyone has this box working ? attached is current tune, logs and photo of knock block normal settings, but even on F and F "test mode" i dont get any values

 

 

evo_knock.zip

Edited by paulr33

Share this post


Link to post
Share on other sites

The only setting I see wrong in your config is the pull-up is turned on on DI1, this should be off for the Knockblock.  If you plug head phones in to the knock block do you hear engine noise?

Share this post


Link to post
Share on other sites

hi all, i have the knock block finally working and i have working knock input. i have the knockblock set to gain 2 and filter C on the box and basically any amount of driving, regardless of how hard i drive the car the knock level goes crazy and the ecu basically thinks there is heaps of knock. is the gain too high ? should i try a gain of 1 or 0 ?

Share this post


Link to post
Share on other sites

All sorted, this is how it's intended to work and the I've realised I now need to set the knock target map. So having knock values all over the place isn't an issue, it's only as useful as a correctly configured knock target map

Share this post


Link to post
Share on other sites

hi all

if i am driving and put the clutch in at around 20km/h i get this excessive and recursive idle hunt sequence, when the engine tries to idle, and basically hunts its ass off between 2000rpm and 1500rpm in constantly cycle.

it looks like this in the logs;

idle_hunt1.thumb.png.32d0385727c144d0590

 

i did some more digging in the logs and found im triggering overrun fuel cut, so if i overlap overrun fuel cut on the engine speed plot, we get this view;

idle_hunt.thumb.png.a3677205ef0c9c862eba

basically the engine is trying to idle, trips over run fuel cut and then runs in a cyclic idle hunt - drives me nuts when im trying to coast down my street quietly and this 2.3L evo is hunts its ass off between 2000rpm and 1500rpm.

so question - is overrun fuel cut the cause of the hunting or is it simply a control mechanism and something else needs to be adjusted? did some reading and understand the intent of overrun fuel cut - maybe i just try disabling it?

its based on deactivation RPM and is targetted at 1600rpm at 80deg water temp (the above example)

 

i also have an issue where hot start works first shot, runs for 2 seconds then blips and almost stalls and recovers, incredibly annoying...

3_sec_stall.thumb.png.395ece633fbc6c5973

from the help;

 

Startup Step - Provides increased air bypass for starting.  Startup step decays as over a period of three seconds after RPM is detected.  In Closed Loop ISC control mode this is a temperature dependant table.

my ISC mode is set to closed loop/sol stepper

startup step is on with +20 for 80deg water temp (this log)
idle rpm target is 1000rpm at 80deg water temp
the logs show it can hold idle, its only when i tries to lower it, that it just stalls rapidly

2.3L with big cams, map sensor etc

should i just increase idle rpm to about 1100rpm and see how that fares?

 

 

 

 

 

 

Share this post


Link to post
Share on other sites

Turn off decel fuel cut for now.  

For idle speed control you need to fully tune it in open loop mode so that the base position table is close to correct before switching over to closed loop mode.

Do this first:

sDXDhFC.png

 

Then do this:

IEyfN6V.png

Share this post


Link to post
Share on other sites
On 10/07/2017 at 4:47 PM, Adamw said:

urn off decel fuel cut for now.  

For idle speed control you need to fully tune it in open loop mode so that the base position table is close to correct before switching over to closed loop mode.

Do this first:

 

FYI just wanted to say thanks for your help with the idle control open loop help, i did this yesterday on my evo with stroker kit, big cams and balance shaft delete so the idle is mega lumpy and following your steps the idle is now a lot better, more stable and predictable and hot start is also prefectly (previously would stall almost every time)

 

Share this post


Link to post
Share on other sites

i think i have picked up a bad batch of fuel and im now getting some knocking levels previously unseen for my car.

i have the ECU setup as follows;

setup.thumb.png.b037ab85d8f49617368dd9cc18b08c0e.png

 

what i was hoping for was the vipec to cut ign timing across the whole tune if it picked up knock and not just the individual cell on the tune.

i want it to be a bit more failsafe instead of just retarding that cell momentarily (for upto 25sec (Advance delay)) and leave it like that - even when keyd' off.

i thought setting "Clear i-trim tables" to OFF would allow me to do this, but the tables are always 0's - both Cyl #1 and #2 - i think its because advance delay is 1s, but the most i can set this to is 25seconds.

 

is there a way to make it cut timing on the whole tune map when it detects KNOCK > KNOCK THRESHOLD (poor mans failsafe)?

 

 

Share this post


Link to post
Share on other sites

Sorry I missed your earlier post.  

If you want the whole operating range to be retarded rather than just a specific cell, then you just change the ign trim table axes so that there is only one cell to adjust.  Example below.

For it to "start up safe", then you turn off "clear I-trim tables".  manually put some retard in the I-trim table, then do a store before powering off.  The ECU will then always start off with full retard applied and only advance up if it doesnt detect knock for the advance delay time out.

yj6N0QZ.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×