Jump to content
Sign in to follow this  
ashfrancis

Link G4 idle problem on a RB30 GTR skyline

Recommended Posts

tried searching for some answers on this through google and it seems all the old forum posts a re gone now so hoping someone can help

 

have an RB30 GTR running a link g4 and have everything running perfect except once the engine is warm the car stalls as soon as you load the power steering or put the ac on, i was perfect until the air temperature has now got lot warmer here.

 

it has an idle control have which may well be the problem, we don't have any information on the hz settings for this one and have just had to go through from scratch and get it running by tryng it.

 

the plan is to buy a new one and try it but before we do that is there an particular on link recommend so we have all the correct information for the setting etc. its to go on a RIPS RB30 converted GTR with single throttle body conversion and single turbo. 

 

als the only other issue we have is if the car is turned off after going on a run as soon as you re start even after a few second the car tries to stall for the first 20 second unless you keep you foot on the throttle a little then it passes and is fine,

 

any help that you can give would be great as the guy thats making it is now pulling his hair out!

Share this post


Link to post
Share on other sites

Could be a number of issues.

It pays to make sure the engine will hold a steady idle with no idle correction.

It might be a case the throttle opening is a little too small at idle.

And as the air temp increases it is just not allowing enough air into the engine.

The ISC base numbers could also be out or the duty cycle is maxed out (butterfly not open enough)

There could also be a IAT fuel trim that is not quite correct and the mixture is off causing the idle to become unstable.

This could also be the case on hot restart too.

Share this post


Link to post
Share on other sites

many thanks for the advice i will pass this on, we had the car ticking over perfectly without the idle control valve connected but as soon as the ac was put on it stalled so thats when we started bringing the control vale back into the equation

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...