Jump to content
Sign in to follow this  
Alex182

Skyline R34 plugin Link - Sensor wiring

Recommended Posts

Hi everybody,

 

we've started tuning a r34 Skyline with a Link G4+ plugin ECU and currently facing some issues/ questions.

 

- Narrowband Lambda seems not to be connected at the Link (Error Code). When changing to closed loop fueling and selecting wideband (which we have connected and works in general) - fueling won't be corrected.

- Don't you have any speed signals from ABS sensor or the trans within the original harness? How to set this up to be able to use traktion and launch control. Abs Sensor wires directly plugged to the ECU?

- When installing GP Input Switches do I have to wire them to a 12V source and the DI 1-8 used as ground?

- The original Knock Sensors cannot be used within the G4+, right?

 

Sorry for those poor questions - It' our first time tuning a standalone ECU :smile:

 

Many thanks in advance!

Share this post


Link to post
Share on other sites

Hi

 

Im assuming its a R34 GTT not the GTR R34?

 

On the R34 there is a speed input from the gearbox on Di4

The wheel speed sensor are not wired directly to the ECU so if you want traction control you will need to add wheel speed inputs via the XS connectors.

 

The Narrow band sensor is wired to AN Volt 2 on pin 50. The sensor when the engine is not running will often read 0V to stop the errors you will need to set the error low value to 0V.

 

The Di inputs can accept either a 12V or a ground input. If switching to 12V the internal pullup on the Di will need to be set to off.

 

The stock knock sensors are able to be used if you wish. You will just need to configure the knock control.

 

The closed loop fuelling should work so this is likely to be a configuration issue. We can look at your map to see the set up of this if you wish.

Share this post


Link to post
Share on other sites

Hi

 

Im assuming its a R34 GTT not the GTR R34?

 

On the R34 there is a speed input from the gearbox on Di4

The wheel speed sensor are not wired directly to the ECU so if you want traction control you will need to add wheel speed inputs via the XS connectors.

 

The Narrow band sensor is wired to AN Volt 2 on pin 50. The sensor when the engine is not running will often read 0V to stop the errors you will need to set the error low value to 0V.

 

The Di inputs can accept either a 12V or a ground input. If switching to 12V the internal pullup on the Di will need to be set to off.

 

The stock knock sensors are able to be used if you wish. You will just need to configure the knock control.

 

The closed loop fuelling should work so this is likely to be a configuration issue. We can look at your map to see the set up of this if you wish.

 

Hi,

 

thanks for your reply!

 

I already tried using the DI4 input to control the Launch control. The limiter did not went off.

I now configured the map with your remarks. It would be nice if you could take a look on it and whether the basics are set up proberly.

 

The Knock Sensor reads 0V. I've set the Error low value to 0V for this one., too. Unfortunately I can't which it to ON in the Knock setup ?!

 

Here you'll find my current map.

https://dl.dropboxusercontent.com/u/18326195/20150706_v1.pclr

 

Many thanks in advance!

Share this post


Link to post
Share on other sites

For the launch control the DI activation is geared to be a on off type switched input. Looking at the MAP this should be set as Di6

Looking at the set up of the Di the switch should be wired to ground.

 

The launch control also operates of the non driven speed input so be sure to set a non driven speed in the speed sources menu.

Note it can use the same source as the driven speed.

 

The Knock used to be an upgrade option. To get the knock working you will need to upgrade the firmware to 5.4.x

You can then set the knock to ON Knk internal.

The sensors are not wired to a AN volt they have there own input.

Share this post


Link to post
Share on other sites

For the launch control the DI activation is geared to be a on off type switched input. Looking at the MAP this should be set as Di6

Looking at the set up of the Di the switch should be wired to ground.

 

The launch control also operates of the non driven speed input so be sure to set a non driven speed in the speed sources menu.

Note it can use the same source as the driven speed.

 

The Knock used to be an upgrade option. To get the knock working you will need to upgrade the firmware to 5.4.x

You can then set the knock to ON Knk internal.

The sensors are not wired to a AN volt they have there own input.

Hi,

thanks for that tipps. It helps me alot with the setup.

 

But I'm still a bit confused about the LC settings.
I've set the LR wheel speed also for the non driven wheel speed in the speed settings.

Set the LC to 2D LC with DI6 switch and 8kph for disabling it at that speed. But we're still hitting the rev limiter while driving until switching DI6 again.

Knock control works just fine now, since I've done the firmware upgrade - great thing! If I understood it right, I cannot use the DI5 port for a Switch on mass when knock control enabled, right (pullup resistor)? Is it okay to run that siwtch on DI5 via 12V though?

By the way:
Do you have any sources for Standard views for the different screens? Would like to have some examples set up nicely. My view looking messier each time im working on it :-)

Regards

Alex

 

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...