Jump to content
Sign in to follow this  
Konstantinos Korres1436215376

New Firmware and DisplayLink

Recommended Posts

hi , i just updated my Link G4 to the new firmware and the DisplayLink attached stopped working. Communication is ok but the problem seems to be firmware incompatibility , the error message the DisplayLink displays is 'Update ECU Firmware'. There was no warning for DisplayLink incompatibility after the update in the Firmware changelog, Have i done something wrong ? I suppose not , I would appreciate some help , thanks.

Share this post


Link to post
Share on other sites

Hi

An easy one to fix. The new firmware runs at a higher baud rate (115200) If you connect to PC Link and change this baud rate back to 57600 the display will be happy again.

Share this post


Link to post
Share on other sites

Only applies to G4 not G4+ and the firmware is in the PC link download.

If you are communicating over can you will need to make sure you have set up the CAN in the ECU correctly.

See attached

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...