Jump to content
Sign in to follow this  
René Berthelot

Siemens injectors dead time

Recommended Posts

Hi

I have a G4+ Extrem ECU

I have Siemens 107961 injectors

The information in your online help for these injectors indicates a dead time of 0.379 ms for 14V under 45psi, but my provider (034 Motorsport), like many other, indicates 1.14 ms at 14 V (http://store.034motorsport.com /siemens-60-pound-or-630cc fuel-injector-high-impedance-20687.html) !
I also found on the net other values such as here: http://www.fiveomotorsport.com/107961-siemens-60lbs, or here http://injector-rehab.com/shop/lag.html

With which values I have to set the table?

Thanks

Share this post


Link to post
Share on other sites

Hard to know. I would go with the source you trust most.

The only real way to know would be to measure your injectors to confirm what they need.

Share this post


Link to post
Share on other sites

Hi,

René and I are still struggling to get his engine to run or even start.

Best we ever did was to get it idle for 2 min then the lambda went lean for no apparent reason (we checked all enrichment tables) and the engine stalled. It's then been impossible to start it again. We varied the Master fuel between 5ms and 18ms, with no success.

Who should I send the cal file to in order to get some help?

I have been successfully using Link/Vi-PEC ECUs on some other engines, but this one is giving me a hard time.

Thanks.

Share this post


Link to post
Share on other sites

Hi Dave,

The engine is finally running, I had to set the trigger offset to -45 ° when it was operating with 315 ° before, I would like to know why it changed ???

We did some roaddrives tests Thom and with almost no Bosst and it works pretty well but now I have two problems:

- Idle is at 1300 rpm with 35 in the "Idle position base table" and 850 rpm in the "Idle RPM table". If I  DECREASES the value the engine speed INCREASES!!! and if I INCREASES the value the engine speed  INCREASES TOO !!! the minimum is reached for 35 ????
- I can not turn on the knock control. When I select "On - Knck Internal" it comes back automatically to Off, if I select "On - Knck DI interface", the menu opens correctly. All G4 + Xtreme have well the internal knock control function?

Thank you for your answers

Regards

René

Share this post


Link to post
Share on other sites

Hi Rene'

I am unsure of why your trigger offset has changed, unless you also changed something in the triggers , for example trigger edge falling or rising, pull up on or off, not sure.

Are you using IDLE IGNITION TIMING TABLE ?

Or running the idle timing off the main ignition table.

What type of idle device does it have or is it DBW.

LINK G4+ XTREME, I am unsure if Knock Internal Control is a standard or an option on this model, I will have to look that up sorry.

Regards

Dave.

Share this post


Link to post
Share on other sites

Hi, Dave

Thank you for your answers

I tried with and without the idle ignition control and it does not change. I'll try to reduce the timming in the main ignition table. I'ave a two wires solenoid valve.

For the trigger offset, I had absolutely nothing changed, I checked the file with which the engine had been running. It's not very important, it runs now, it was just to know the explanation.

Regards

René

Share this post


Link to post
Share on other sites

Some solenoids will start to open at low duty cycles the Bosch 2 wire will start to open below 30%. I would block this off and see where the idle sits.

If its still high and you only have 5 deg of timing then there is an air leak or the throttle stop is open too far.

Share this post


Link to post
Share on other sites

I shall close the Idle solenoid to try but the idle speed was well with the OEM Motronic ECU and i'm sure that there is no air leak. It is not the principal problem.

The most important is the Knock control. Can you confirm that all G4 + Xtreme have the  internal knock control module?

Regards

René

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...