Jump to content
Sign in to follow this  
Mike Mcnab

Throttle fault

Recommended Posts

My 1972 T2 bay window camper has a Subaru Impreza engine fitted from a 2007 WRX, running the link ecu. The fault is that it does not idle and when it does it runs irratic, also when driving the camper surges. I have been advised that the pedal requires re syncing to the throttle body. Does anyone know if this is possible and if so how do you do it?

I have also been advised that it requires a firmware update, anyone know how this is done?

Any feedback would be much appreciated. Thanks

Share this post


Link to post
Share on other sites

Hi Mike

All can be done through the PC tuning software.

I would not recommend doing a firmware upgrade unless you have the knowledge to check all settings including fuel and ignition figures. I would suggest leaving this to the tuner.

The help file in the PC tuning software will cover most set up questions.

This can be down loaded from here http://www.linkecu.com/support/downloads/pclink-download/pclink-g4-v4-9-9.1784#

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...