Jump to content
Sign in to follow this  
Chris Bell

Link Electric fan

Recommended Posts

Hi guys just joined the forum as I finally got a link! I am having one problem though, I am using an electric fan but when the fan turns on the car turns off :S I had the link installed and the wiring for the fan done by a shop, but the shop is abit far away and I know basic circuitry so I want to have a go at fixing it myself. Iv attached an image of the diagram just wondering if anyone can see the problem. Thanks

post-1324-143621565328_thumb.png

Share this post


Link to post
Share on other sites

As per Page 18 of http://www.linkecu.com/support/documentation/g4-engine-management-documentation/G4Install

 

You'd wire the connection '+ECU' to +12V (Battery)

I don't know why the connection of the left side of the relay (+ECU) is connected to any point on the ECU, the current draw of the fan could give too much voltage drop to the ECU and cause the ECU to shut down..

 

Share this post


Link to post
Share on other sites

No, the wire you have labelled 'ECU-' would go to whatever pin you want to be the output. So one of the Aux output pins. The wire labelled '12V Constant' is correct.

 

Note that you want a fuse between the relay and the battery.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...