Jump to content
Sign in to follow this  
Incognito G

PCLink disconnecting at 15 Psi

Recommended Posts

Anyone has any experience with this? When boosting 10 psi and the pc is connected to Link G4 Storm, it doesn't get disconnected and I can do real monitoring. However when boosting 15 psi after 5000 rpm the PC Link gets disconnected from the ECU

Share this post


Link to post
Share on other sites

This is likely to be electrical noise being radiated at the higher cylinder pressure levels.

Check all leads, plugs and coils are in good shape. Plugs must be resistive if running wasted spark.

Share this post


Link to post
Share on other sites

I have the same problem with Mitsubishi Evo VIII However when boosting 240 Kpa after 5000 rpm the PC Link gets disconnected from the ECU, and datalogging don't help me in the work mapping........then I disconnect the USB Cable, reconnect and all is ready for work Next weeks I try mapping Subaru STI 07 with DBW......I hope don't have this problem

Share this post


Link to post
Share on other sites

High power disconnects are almost always caused by interference from the ignition system upsetting communications.  It is and always has been a problem on EVOs with most types of aftermarket ECUs.  Further, it is almost always cured by changing the spark plugs to standard resistive types.  Racer type plugs can be fitted after tuning.  Even some performance type spark plugs claiming to be resistive will cause problems.  Also, Good resistive type HT leads must be used.  the following is from the PCLink help regarding disconnect problems:

 

This section provides information on and solutions to problems encountered communicating with Link G4 ECUs.  The majority of communication problems encountered by Link technical support are caused by one or more of the issues listed on this page.  It is very infrequent that communication problems can not be resolved.

 

Feedback has shown that under certain conditions (usually full power) communications problems can cause the following symptoms:

 

· ECU disconnects completely from PCLink.
· PCLink freezes momentarily.
· USB communication breaks and wont reconnect until the cable is disconnected or PC is restarted.

 

The cause of these problems can almost always be traced back to electrical interference.  Electrical interference is generated by ignition systems and switching on and off of solenoids/relays.  Under most circumstances USB communications is robust in an automotive environment.  Unfortunately, excessive electrical interference can compromise the integrity of the high speed signals.

 

If communication problems are encountered, the following items MUST be checked (NEVER assume they are correct):

 

· Fit Standard Resistive Spark Plugs - Nearly all ECU communications problems encountered by the Link technical support department are caused by the use of non resistive plugs or HT leads.  Even race plugs that state to be resistive type may not suitable.  Remove these plugs and refit after tuning is complete.
· Fit Resistive HT Leads - Non resistive leads are a source of ignition noise and are not suitable for use with most modern ignition systems.
· Check All Grounds - Check all ECU and engine grounds are clean and well connected.  Perform measurements if necessary.  One installer reported communication problems that were a result of poor ECU grounding through a main engine loom connector that had been added to allow easy removal of the engine!
· Check Wiring and Install of Igniter and Coils - This is particularly important where after market igniters or coils are used.  Consider the following points:
1. The igniter must be grounded with an appropriate rated wire to the engine block (and to nowhere else!).
2. Power supply to coils must be fitted with a suppressor.
3. Coils should be positioned to minimise HT lead length.
4. Igniters should be positioned to minimise wiring length to the coils.
5. Igniters designed to ground through their mounting bolts must be mounted to the engine block.
6. If fitting coils from another engine, ensure the mounting frame provides grounding for the metal coil body.
7. Some coils require a ground wire connection from their main connector to the engine block.

 

If USB communication can not be made stable, all Link ECUs are equipped with RS232 (serial) communication port.  This allows direct connection of the ECU to a PCs serial port eliminating USB communications completely.  A lot of modern laptops have no serial port fitted.  A USB-Serial converter can be used, but it is likely that communications will fail as USB communication is still being used between the PC and the adapter.

Share this post


Link to post
Share on other sites
Guest

Had the same problem at 5500 RPM at 9psi, I ran 3 earths from 6 coil packs, also ran the ignition loom on its own and now everything is working as it should :D

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...