Jump to content
Guest |141|

Re: AIM Dash Setup with Vipec

Recommended Posts

Guest |97|

My list only shows the likes of VP_GPPress_AN4 etc. How did you get yours to show oil/fuel pressure?

Can I email you a copy of my config?

Share this post


Link to post
Share on other sites
Guest |141|
My list only shows the likes of VP_GPPress_AN4 etc. How did you get yours to show oil/fuel pressure?

Just rename it :)

Share this post


Link to post
Share on other sites
Guest |97|

I have the absolute latest firmware and software for the dash.

I confirm that the displayed values for the oil and fuel pressure sensors and afr are raw voltages.

Share this post


Link to post
Share on other sites
Guest |141|

make a screen shot of RaceStudio Online values.

I have no problems with V88 connected to MXL Pista

p.s. I also connected Motec dash to ViPEC V88, it shows and displays values the same as is displayed on AIM dash.

To make it work perfect, we should ask ViPEC engineers to make datastream outputs the same are made for:

IAT

ECT

MGP

MAP

for:

Fuel Pressure

Oil Pressure

EGT

Wideband1

Wideband2

....

Share this post


Link to post
Share on other sites
Guest |732|

I got mine setup and had data coming through to the dash straight away. This was even with the default settings of baud rate - 115200 and datastream - OFF. After changing some settings on the dash and on the ECU and re-starting the car a couple of times I now don't have any data coming from the vipec to the dash. I tried changing the settings to the ones listed and still no data. The dash is still working with direct channel inputs just nothing from the ECU. I metered the cables and checked connections and all that side of things is ok still but it seems like the vipec isn't sending any data anymore. Has anyone had an issue like this? I have even defaulted the ecu and dash and started again with no luck?

Share this post


Link to post
Share on other sites
Guest |732|

For some reason I couldn't get mine to work on the older firmware. With the new firmware upgrade it works perfect like this:

Baud: 19200

Datastream: Off

Share this post


Link to post
Share on other sites
Guest |759|

I ran into a strange problem with the AIM strada connected to the vipec v88. Suddently I couldnt get oil and fuel pressure to work on the display. I works in the vipec program so i know that the sensors are working correctly, so the problem must be in the AIM setup.

Oil pressure is connected to an volt 2 and fuel pressure is connected to an volt 4, in the AIM racestudio software is use the channels called VP_GPPres_AN2 and AN4. Does anybody know what I`m doing wrong? It worked before

Share this post


Link to post
Share on other sites

To my knowledge race Technology support our ECUs directly through their ECU serial adapter. I have tested one here on the bench and it was all working. All ViPEC ECUs can be used to talk to the dash. From memory they have instructions included with the ViPEC ECU adapter on how to set it all up and get it working (baud rates etc).

From the Race Technology website: http://www.race-technology.com/wiki/index.php/ECUType/ViPECV44V88AndLinkG4

- Set the ECU to 57600 baud rate.

- Select the data stream mode to Requested Short (not OFF as they say!)

Also, make sure that the USB cable is not connected while trying to communicate with the dash on serial. Also, remove the dash cable while the USB cable is plugged in.

Regards

Ashley Duncan

ViPEC Engineer

Share this post


Link to post
Share on other sites
Guest |167|

How will these dash displays work with the new can data stream from the Vi-pec ecu's? Is it some kind of standard datastrem, or can we setup the data exactly as we want?

Do we need to get the dash manufacturers to make support for the Vi-pec can data?

It's in particular the Race Technology dash that's on my mind, but I assume the answer will be valid for other displays as well.

Share this post


Link to post
Share on other sites
Guest |141|

For AIM it will be default data stream (you can see what it sends on CAN bus - go to CAN setup, then load file: Generic Dash.lcc).

Share this post


Link to post
Share on other sites

Most displays are configurable and the ViPEC ECU is configurable. Here is what I know about displays on CAN so far:

MoTeC : Configurable in dash and ECU. Setup files for ECU and dash included in VTS install.

AIM : Dash not configurable but now supports ViPEC ECUs on CAN if the ECU is set to use the Generic Display file.

Race Technology : Their CAN ECU adapter can be configured to communicate with the ECU. ECU can be configured to suit. Number of parameters is limited by their adapter.

DashDAQ : Serial support, but no CAN yet.

ViPEC Display : Serial or CAN, use Generic Display file for CAN.

RacePak : Serial supported, not sure about CAN yet.

Regards

Ashley Duncan

Vi-PEC Engineer

Share this post


Link to post
Share on other sites
Guest |109|

Hi,

i just updated to the latest firmware over the weekend, and while everything seemed to work ok, the aim dash does some very wierd stuff now ...

speed will jump from --- to 896kmh then to 384 then to another random number - the odo is also skipping around - up and down ... !

the other parameters seem to display ok ... have checked config setings on ecu and all seems to be as it was previously ... 19200 datastream off ...

any ideas ?

Share this post


Link to post
Share on other sites
Guest |109|

sorry, its datastream set to requested short ...

have updated to the latest AIM firmware - still the same issue ...

looking at the vipec software the speeds are being reported ok - but looking at the aim online software the speeds are massivly out of proportion ... seems like the values being passed to the dash are the raw values, not the calculated values from the calibration table maybe ?

HELP !

Share this post


Link to post
Share on other sites
Guest |109|

Thanks for the reply

i'm fairly sure there is not a way to reduce the multiplied value in the aim race studio software ... you just get an option to select the sensor ..

can i create a a virtual speed sensor and take the actual value and divide by 100 in vts to send to the dash ??

thanks.

Share this post


Link to post
Share on other sites
Guest |109|

doesnt look like there is a solution for this - i ended up having to run another wire from the ECU (spare injector output) to the dash for 'speedo output' and stuff around with both dash and ecu to get it working ...

:(

Share this post


Link to post
Share on other sites
Guest |141|

what versions are you using? We have no problem with speed channel from ViPEC to AIM. Dash shows exactly what VTS is showing

Share this post


Link to post
Share on other sites
Guest |717|

Hi All,

I have everything working as sold, but want to know if there is any updates to the "GenericDash.lcc" file possibly in the future so we can customise our set up to have AN1 to 11 and DI1 to 10 inputs from the ECU sent to the AIM dash the way we want it????. For example, i have some of the AN inputs to the ECU as additional pressures, temps and quantity values that i would like the dash to display and log.

I am using the AIM MXL Pro05 dash as the chassis tuner/ Data Logger and the ECU V88 as the engine/ performance data logger. With this set up i would like to have some engine vitals sent to the dash for safety reasons as every one would agree. ie, engine oil + water, temps + pressures, gearbox temps, ambient temps, engine speed, vehicle speed, etc, etc.

I know in the ViPec software how to change the CAN data that goes to the AIM, but the AIM dash CAN input data needs to be changed to coincide with the data i am inputting into it.

Is there a way to change the GenericDash.lcc file so we can choose what we want to display/log, or are they working (AIM and ViPec) on another "Dash.lcc" file for the ViPec CAN Bus???

I'm sure it would be just a matter of opening the file in word and setting or readjusting the parameters to record all the ViPec's AN's and DI's inputs and/or other requirements for that matter???

I hope you are able to give us some idea as to what, or if you guys are working on this matter and if it is going to be a long or short time frame till we get an answer????

I love both the produces and for me they were always the first choice, seeing now that Autronic is not keeping as up to date as required...... Boo Hoo, I loved my SM2... it served me well for 15+ years. Sold with car.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×