Jump to content
edwin opie

HONDA k20a ignition coil dies

Recommended Posts

hi there, finally i can start g4 on k20a engine, but after 1 minute smooth idle the engine stop runing. and cant start again. after i checked, the ignition coil is not firing. and it was getting hot. the dwell time is 4.0 ms. is my dwell is too high, so it kills the ignition coil? what is the appropriate dwell time for this kind of ignition coil. what others thing to watch beside the dwell time, that make the coils get hot? thx.

Share this post


Link to post
Share on other sites

i know this was posted a very long time ago. but hope someone help. can anyone confirm if these coils need a rising or falling edge ? also was the 4.0ms dwell angle correct for these coils. ? also is it normal for them to get EXTREAMLY HOT ??

thanks

Share this post


Link to post
Share on other sites

These are a good set up for K20A coil on plug coils, comes Motec website. 

8

4.8

9

3.5

10

3.0

11

2.5

12

2.1

13

1.8

14

1.7

15

1.5

Just now, AbbeyMS said:

These are a good set up for K20A coil on plug coils, comes Motec website. 

8

4.8

9

3.5

10

3.0

11

2.5

12

2.1

13

1.8

14

1.7

15

1.5

 

Edited by AbbeyMS

Share this post


Link to post
Share on other sites

thanks for the responses. thats how i had mine set just wanted to confirm the data. 

i am very very confused tho. as i have just fitted x4 brand new k20 coils. i have copied the wiring from a k20 wiring diagram. pin 1 ecu pin 2 earth pin 3 +12v . pin 1 being the pin closest to the clip side of the plug. i have run ignition test and all 4 coils click. the car started and run also. 

went back down to the car today to check some stuff. had ignition on engine off as was checking some stuff and could smell burning. checked coils and all 4 coils have completely melted! 

i am confused as i have copied the wiring from others that are running these coils. what can cause this ? as I'm lost and very annoyed as thats £150 down the pan!!

any help to get this sorted would be much appreciated. at a complete loss here!

fucked.jpg

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...