Jump to content
Sign in to follow this  
Neil Clayton

Confirm understanding of ECU pinouts (serial)

Recommended Posts

I've Link G4 Plugin.

The manual says that there's some RS232 pinouts on the ECU connector. I'd like to confirm that this is indeed the case (primarily because I don't seem to be able to talk to it).

Is it expected that assuming I have my baud rate setup correctly, that I'd be able to power on the ECU - and send it a 'W' command to do a status check?   I'd expect to be able to send W and see 'something' on my telnet session (I'm connecting via a Ethernet->Serial converter that we've checked is working OK).

The ECU itself is in the car, working, configured - and I can talk to it fine over the USB link using the PCLink s/w.

Is there anything I have to configure apart from Baud, bits, parity on the ECU before it'll talk to me over serial?

Thanks in advance,

Neil

Share this post


Link to post
Share on other sites

Hi Neil,

Because your ECU is a plug-in you will probably need to change the plug setup. If you unplug the tuning cable from the top-board in your ECU and plug it into the plug on the bottom board (Normally labelled RS232/CAN) you should hopefully be ok.

Cheers,

Scott

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...