Jump to content
Sign in to follow this  
Antony King

G3 upgraded to run G4 firmware

Recommended Posts

Pricing is dependent on location in the world.

The biggest draw back to the upgrade is the time involved in transferring the G3 map over to G4. The numbers have to be manually copied over.

Share this post


Link to post
Share on other sites

Yes the boost control is definately going to get you closer to the mark now as you can span the table axis over almost anything that makes sense now.  The older G3 firmware would only let you do RPM on the X axis and only a few options for the Y axis (and none of those options were MAP).

Given you can now span over MAP, this allows for a lot more accurate boost control.  The most noteable difference running the G4 firmware would be the logging ability, the ability to configure 3D tables in lots more ways and true fuel correction based on IAT on the fly.

You will also gain other new features such as virtual auxilaries, engine codes by way of your engine check lamp indicating specific problems without having to connect, and various others.  And of course you will get ongoing free downloads of up and coming new features in the G4 firmware

Jurgen.

Share this post


Link to post
Share on other sites

It's just a time thing Matt.  After performing the upgrade, a reload of factory settings is imperative as part of the process, and needless to say, so is saving your map BEFORE you start.  After the upgrade and reload, the time consuming thing is manually setting it all up again.

Not too bad in reality, as long as you follow the process.  You CANNOT just load the old map up because there are memory addressing changes in the background you have no control over.  However to make it easier you can keep PCLink 3.5 open (with your saved map from G3 vers. open in it), as well as PCLink 4.4.x (connected to the ECU).  Yes they can both be open at the same time, but only one connected.

Fuel and ignition wise, as long as you set up the axis in all of those tables exactly the same (rows and columns), you will be able to copy and paste the numbers across in one hit pretty much, eliminating the need for a 're-tune'.  The super important thing will be to MANUALLY set up all your DI's, AUX's and other functions using the old map as a reference only.

Note that what was labeled as AN LOAD 1, 2 and 3, on the G3 is now called AN VOLT 1, 2, and 3 on the G4 firmware.  And in turn AN VOLT 1, 2 and 3 on the G3 will now be AN VOLT 4, 5 and 6... 4, 5 and 6 now 7, 8 and 9 and so on.

Hence, it is considered time consuming :)

Jurgen

Share this post


Link to post
Share on other sites

If you are from another country do you have to return your ECU to Link  in order to upgrade your  G3 to use G4 Firmware?

How is it done?

Do you set up the initial map and sell the software?

Whats the cost associated with this?

 

I have bought this G3 for a while since I am in college , still in College

and i wii like to use the g4 firmware.

Share this post


Link to post
Share on other sites

Hi All, I have done the upgrade from G3 firmware to G4 on a subaru MY03 STI plugin. The firmware update process itself is over within 11 seconds. Be warned, the rest does take a few hours to complete before you can startup again. My case it took me about 4 hours to recheck every setting and compare to the old map. You will need to use some logic to apply some values that were 'global' before to a new scaled map for the same settings..nothing complicated though! Caution when you complete the upgrade and fire up new pclink you will receive many prompts asking you to set axis setting for various tables (this scared me but nothing to really worry about). I Chose 'none' where possible or the first option and worked thru them. Note - the ecu will disconnect if you don't chose anything..so you have to work thru this.. Once all this is done, the ecu comes up. Now you will need to check every setting and turn off maps you never had before as a starting point. The copy paste of maps works VERY well as long as you set your X and Y scaling EXACTLY the same as your old map..PS the copy paste will NOT work if your scaling does not match EXACTLY- great safety to rely on! Next I dealt with the different fault codes from the sensors (i had a few). RTFM :) on how to set the low/high error settings. Currently have one error OverCurrINJ 1/2..Simon has asked me to download and reflash with the latest pc link. My car is running but I seem to be 'rich 'pretty much all over the maps(I have 2) at the moment. Hoping that the OverCurrInj 1/2 error is the cause of the overfuelling. It's taken ALOT of time to build my maps..I am really hoping I don't have to remap. Will reflash tonight and check afrs..will keep all posted.

Share this post


Link to post
Share on other sites

Hi Ash.

Try having a look at the 'IAT Fuel Correction', as this was a feature that is new and could be adding fuel to the map thinking the intake air is colder than it actually is.  It's found under Fuel/IAT Fuel Correction... Turn the state of this to OFF to prove it, as this would not have been operating on the G3 base.

Jurgen.

Share this post


Link to post
Share on other sites

Hi Guys, I have sent previous emails to Simon..no response..I assume he is busy. I need help URGENTLY from ANYONE at tech support: 1. I have upgraded my G3 WRX plugin on my 2003STI to G4 firmware (FirmwareConfirm.png) 2. I have flashed the firmware twice now and followed the instructions to the letter twice...hours of work X 2 ïŒ 3. My maps were all running way richer despite checking every copy and paste , EVERY setting and every X Y scaling – finally gave up and just remapped the car(both my pump gas and my high octane map)!!! 4.Now I have two major problems left and 1 minor problem a. VVT Error on Inlet/LH Target = Error: 4th Cam Pulse + Error: ExtraPulse (manual says contact link dealer) b. OverCurr-INJ 1/2 :Error (Could this cause my over fuelling issue- asked Simon before..no answer yet..How to fix this) c. On Digital inputs tab – not displaying gear (minor problem) I am running the latest version of EVERYTHING: PCLINK 4.4.1.251 Build 11:11:14 Jul 30 2009 (PclinkConfirm.png) My map is attached. PLEASE HELP GUYS!!! Thanks!

Share this post


Link to post
Share on other sites

I have had a quick look at your file and i see that vvti table is not setup so cam control will not be working   making the engine run richer than before if the camcontrol was previously setup    as well as you have not turned on IAT fuel correction.

What type of injectors are you running?

check your ign 1 map as well there are a few odd numbers in the higher boost rows.

Regards

Dave

info@dtechmotorsport.com

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×