Jump to content
Sign in to follow this  
Sameh Yehia

VAG Audi R8 Coil weak spark

Recommended Posts

Hello
i am using Audi R8 Coilpacks on BMW M52 
Wasted Spark using ign 1 -2 3
car starts but the spark plugs sometimes get fouled..i tested the coil but the spark is weak 
pin 2-4 signal and power ground is connected together to engine block 
spark edge is set falling
what could be the issue causing that?

Share this post


Link to post
Share on other sites

A week power supply to the coils could be one thing.

Check you still have a full 12~14V at the coil while the engine is running.

Share this post


Link to post
Share on other sites

Hi Simon,
yes i have 13+ volt at while engine is running and same battery voltage engine off 12v...i guess this is enough to show strong spark...but my spark is very short even if you try to make a metal to metal contact it wont catch up to any close metal piece 
i gave pin 2-3 extra ground to the engine block
what about the spark edge ? any one knows the correct spark edge for these coils ?
its 06E 905 115E part number
 

Share this post


Link to post
Share on other sites

tried rising edge too
from searching around i read some people use an extra buffer circuit as these coils is low resistance,i tested my coils and it's 388ohm,can the link drive these coils? if not how to build that circuit ?

Share this post


Link to post
Share on other sites

Yep that is plenty high enough. As they are smart coils the current draw on the ECU will be very minimal.

Have you tried different dwell settings?

Share this post


Link to post
Share on other sites

Hi Sameh,

you may need to lift the dwell up some.

Set to around 3.5 ms at 12 -13 volts from 1000 to 3000 rpm then drop to 3.0 ms through to 7000 rpm

Set to around 4.0 ms at 12 - 13 volts from 1000 to 3000 rpm then drop to 3.5ms through to 7000 rpm.

Remember

The higher the voltage the lower the dwell needs to be.

The lower the voltage the higher the dwell needs to be.

The higher the RPM the lower the dwell needs to be.

Are you using resistored or non resistored spark plugs with these coils.

Regards

Dave.

 

Share this post


Link to post
Share on other sites

Not sure if you've solved your problem, but just in case:  You could also try copying the ignition/dwell settings from the Audi TT base file (you should have this file from when you installed the PCLink software), since it is setup to use very similar ignition coils.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...