Jump to content
Joseph Yong

Altezza Trust turbo fuel gauge not respon

Recommended Posts

Hi I just install Link G4+ PLUG IN to my altezza , need to check will the new ecu effect the fuel level gauge? I have pump full tank and the gauge is show full but after drive 150 km the gauge still show full. 

Share this post


Link to post
Share on other sites

put one in a local car and the gauge goes down in quarters unfortunately, same as when you remove the stock ECU and wire in an aftermarket ECU that doesn't talk on the Toyota multiplex bus

Edited by JMP

Share this post


Link to post
Share on other sites

We have a solution for the Link G4+ Altezza Plug-in ECUs in the final stages of testing. Once we are happy with the testing we will be able to upgrade existing G4+ Altezza Plug-in ECUs if they are sent in to us.We will do the upgrade and return shipping free of charge.

Share this post


Link to post
Share on other sites

We have a solution for the Link G4+ Altezza Plug-in ECUs in the final stages of testing. Once we are happy with the testing we will be able to upgrade existing G4+ Altezza Plug-in ECUs if they are sent in to us.We will do the upgrade and return shipping free of charge.

20151123_1653071.mp4?dl=0I Have Problem With My RPM meter after install the ECU , is this problem related to ECU?https://www.dropbox.com/s/ydulwg2ffsngtcd/20151123_1653071.mp4?dl=0

Share this post


Link to post
Share on other sites

Assuming it is doing that at key on and not while the engine is running?

If this is the case it is just the ECU doing a tacho sweep.

The tacho is not controlled via the bean network which is what the fuel gauge is controlled through.

 

 

Share this post


Link to post
Share on other sites

Does the tacho do this just at key on, and then function correctly? If yes, then there is no problem. If you do not want it to do this at key on set the Key ON Sweep to OFF. This is under the Tacho configuration options at the bottom of ECU Settings > Aux Outputs.

tacho sweep.PNG

Edited by Scott

Share this post


Link to post
Share on other sites

Does the tacho do this just at key on, and then function correctly? If yes, then there is no problem. If you do not want it to do this at key on set the Key ON Sweep to OFF. This is under the Tacho configuration options at the bottom of ECU Settings > Aux Outputs.

tacho sweep.PNG

Hi Scott,  I am find with the key on sweep future,  my problem is the rpm indicator movement is not smooth look like signal delay. can we adjust it in the pc link? 

Share this post


Link to post
Share on other sites

Hi Joseph,

The frequency of the tacho signal is controlled by the speed of the engine. Try adjusting your Tacho Duty Cycle up and down. Maybe try a value of 30 and see if this improves response.

Share this post


Link to post
Share on other sites

The next step is going to be scoping the signal into the tacho while using the factory ECU and using the G4+ pug-in ECU. Then the signals will need to be compared to see what the difference is.

Share this post


Link to post
Share on other sites

Hi Joseph, not yet. We have made some changes, but are waiting on a dealer of ours to give us the results of the testing.

Are you running the Modelled or Traditional Fuel Equation Mode in your ECU?

 

Share this post


Link to post
Share on other sites

Hi Joseph

Would you be willing to do some testing?

Catches are that ECU will need to be sent in to use for the fix to be applied and then you will need to tune you car in the modeled mode.

 

Share this post


Link to post
Share on other sites

That actual testing is not to bad it will either work or it won't.

The hard part is the tune will need to be changed over to modeled mode which will require the car to be put on the dyno and a tuner do the retune.

It needs to be in modeled mode to give an instantaneous fuel consumption reading which is apparently required for the fuel gauge.

 

Share this post


Link to post
Share on other sites

Hi Joseph, We have the update available, but have not had access to a vehicle to test it on ourselves. For the update we would need to have the ECU back to us to install some new BEAN firmware. The ECU would then need to be tuned using our modelled fuel equation.

Share this post


Link to post
Share on other sites

Thanks Scott.  I can arrange to send back my ecu for firmware upgrade anytime, can you provide me the address? Since I'll send you the ECU will you be able to help me set the modelled fuel equation setting base on my current ecu setting? Will get my tuner to tune once you return my ECU.

Share this post


Link to post
Share on other sites

Hi Joseph, 

See the following for details on sending an ECU into us. For this upgrade we are happy to do the upgrade free of charge and also pay for return shipping to you. We are able to supply advice on setting up up the modelled fuel mode, but your tuner will need to do it as details like injectors specs and fuel system need to be filled in.

http://www.linkecu.com/ECU-Service-Requests

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×