Jump to content
AXA

What is new with PCLink V5.6.1.3098 Firmware

Recommended Posts

In the 'Release Notes' in the help file under the 'PCLink G4+ Users Manual' section it says:

ECU Firmware Version Information:

G4+ Firmware Version 5.6.1.3082 - 31-05-15

New Features

·Support added for the Link G4+ Force GDI ECU.
·Added GDI Pump Control functionality (available only on GDI specific ECUs).
·Added Closed Loop Fuel Pump Speed Control mode.
·Added Open Loop Fuel Pump Speed Control mode.
·Added MAP Sensor calibrations for eight common Bosch sensors and new Link sensors.
·Added Oil Pressure, Fuel Pressure, Oil Temperature, % Fuel Cut, % Ign Cut, Exhaust Pressure, ECU Temperature and Altitude as table axis options.
·Added built in CAN streams for Link CAN-Lambda.
·Ford BA and Toyota 2GR-FE trigger modes have been revised to allow the engine to start on wasted spark and group fuel then switch to sequential for improved starting.
·Added Thermocouple 1 and Thermocouple 2 on EGT11 and EGT 21 OBD PIDs.
·Made so fault codes can be cleared by holding throttle position above 80% for 10 seconds at key on and engine stalled.
·Added Lock Timing Digital Input function to allow adjustment of base timing without PCLink.
·Added calibrations for Honda air and water temperature sensors.

Changes

·Int. Lambda xxx parameters have been renamed to just Lambda xxx as can be written to by external module.
·Under some conditions during fuel cut limiting short injector pulses of 0.2ms could occur.  This would only cause issues on GDI type injectors.
·Maximum MAP Limit has been increased from 500 kPa to 1000 kPa.
·Differential fuel pressure now calculates with 1 kPa resolution instead of 5 kPa and the range is extended.
·Increased the amount of ignition retard allowed in speed limit for pit lane speed control.
·Added Lambda 3-8 to Lambda Average.

Fixes

·Lambda Average did not include analog Lambda 1 at times.
·Plug-ins now show tables 21 - 30.
·Changed VVT solenoid control to become active when engine started, previously waited until speed lockout reached.
·Exclude internal Lambda from Lambda Average when status is not "operating".
·ECT Ign Trim parameter would flicker between the table number and zero when the engine was stalled.
·Inconsistent display of data from Trigger Scope on Thunder ECUs.
·FP Speed (%DC) has been changed to a numerical parameter to display actual fuel pump control duty cycle.
·Fixed support processor firmware update not completing correctly on Thunder ECUs some time.
·MAP Limit did not change its units, was always in kPa.
·Changed Holden V6 Alloytec II VVTi trigger first sync to reduce errors.
·Fix idle speed control RPM lockout sometimes not being applied correctly.
·Fixed Nissan VQ30 triggers occasionally missing the sync point.

PCLink Version Information:

Version 5.x.x.3098 (DLL Rev 3070) - 10-06-16

New Features

·Added support for Force GDI. See GDI Pump Control, Force GDI Header Pinout and Force GDI Specific Wiring for details.
·Added support for Link CAN-Lambda module. See Device Specific CAN Information for details.

Changes

·Added a prompt to the logging setup window to remind the user to perform a store.
·In parameter selection windows; DI 11-16 parameters now display a label, if one is present.
·Boost Control tables now display whether they are active as soon as they are allocated.

Fixes

·Fuel Pump Control - FP Speed table now displays 'Inj Duty Cycle (%)' in the table axis setup as it should.
·Stopped an exception from occurring when the user closed PCLink too soon after opening.
·The load axis on all tables are now updated when units are switched between imperial and metric.
·Audio View now resizes properly (only occurred when it was quite large).
·VVTi Exhaust Target and Anti-Lag Ign table values now round correctly when offline.
·Table graphical view icons now disappear properly.
·Fixed an issue where CAN settings were not retreived correctly on Storm (Black).

Share this post


Link to post
Share on other sites

Hi there,

Already update to the latest firmware v5.6.1.

On the Digital Inputs, Lock Timing did'nt change the state when i switch it to on, Nothing happens. Is there anything else should i do to perform the Lock Timing. 

Thank you

Share this post


Link to post
Share on other sites

Hi

I've installed the newest firmware in my Fury and it looks like the lambda closed loop correction doesn't work in the Auto Mode (Wide Band). Maby user error but don't think so.

Had to roll back to the old firmware...

Regards

Hans

Share this post


Link to post
Share on other sites

Hi there,

Already update to the latest firmware v5.6.1.

On the Digital Inputs, Lock Timing did'nt change the state when i switch it to on, Nothing happens. Is there anything else should i do to perform the Lock Timing. 

Thank you

Hi Dinn,

This is working for me:

https://vdoubleyou-scott.tinytake.com/sf/NzQ4NjEzXzM0MzA5Njk

Can you please post a short PCLog of you attempting to lock timing with the Digital Input?

Share this post


Link to post
Share on other sites

Hi

I've installed the newest firmware in my Fury and it looks like the lambda closed loop correction doesn't work in the Auto Mode (Wide Band). Maby user error but don't think so.

Had to roll back to the old firmware...

Regards

Hans

Hi Hans,

Thanks for reporting the problem. I'm not able to recreate it, here is it working for me:

https://vdoubleyou-scott.tinytake.com/sf/NzQ4NjMzXzM0MzEwNDk

Can you please upload a PCLog of the problem and your base-map?

Scott.

Share this post


Link to post
Share on other sites

Hi Hans,

Thanks for the log. The problem I see in your log file is that lambda Avg is not tracking Lambda 1. I see you have a Fury ECU, are you using the onboard O2 controller, an external O2 sensor controller (An Volt channel), or an external O2 controller (CAN bus)?

Can you please attach your base-map.

Scott.

Share this post


Link to post
Share on other sites

Thanks Scott

Is it also possible to look at Idle Speed Control 3D Table option?

It doesn't work for me to map up for example a matrix with higher idle rpm when car is moving, the duty for the ISV will go crazy and  oscilate from 0% to max duty to the engine stall.

Doesn't have a log for this but it is possible to test in the base file I attached earlier.

Again, it could be user error...

Regards

Hans

Share this post


Link to post
Share on other sites

Hi Hans, 

When I look at your base-map currently I see the Idle base position table and Idle target rpm table are 2D tables with ECT as the axis on both tables. Could you please upload or email (tech@linkecu.com) another version of the base-map where the tables are set to 3D? Also, next time this problem occurs, can you look at the 'Idle Status' parameter and let me know what it is saying (or send me a PCLog).

Thanks,

Scott.

Share this post


Link to post
Share on other sites

I just found Speedo Out cannot work on AUX 17,18 (Thunder ECU). 

I've change to AUX 6 it work normally.

Another found is cannot input the number directly on some parameter such as, Overrun Fuel Cut - Ignition Retard.

But the number can change by press PGUP/PGDN.

Share this post


Link to post
Share on other sites

I just found Speedo Out cannot work on AUX 17,18 (Thunder ECU). 

I've change to AUX 6 it work normally.

Another found is cannot input the number directly on some parameter such as, Overrun Fuel Cut - Ignition Retard.

But the number can change by press PGUP/PGDN.

Hi Joe,

Are you able to set Aux 17 or Aux 18 to Speedo Out? If yes, what happens then? The speed doesn't work at all, or erratic behaviour?

With the over-run fuel cut Ignition Retard, are you able to type in a negative value? Should look like this:

Ignition retard.PNG

Scott

Share this post


Link to post
Share on other sites

Hi Scott

I've sent a mail with base and corresponding log file on the Idle 3D table issue.

Regards

Hans

Thanks Hans, I believe Simon has replied to your email.

Scott.

Share this post


Link to post
Share on other sites

Thanks for letting us know Llewellyn. Can you please tell me which Fuel Equation Mode you are using? And if using one of the Modelled modes, what are you using for Fuel System Type?

Scott

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...