Jump to content
interprodave

MY2005 Sti G4+ exhaust cam target table

Recommended Posts

Interpro Dave,

Where are you located?  In the USA, they didn't implement quad AVCS until 2008.

But as for quad avcs, you will need to select "Subaru Quad AVCS" and then once you have a Digital input and aux outs set up for the exhaust cams, then the exhaust avcs tables will show up under the vvt control menu.

Good Luck

Brad

Edited by Brad Burnett

Share this post


Link to post
Share on other sites

Which G4+ ECU do you have? If using one of our 'WRX Version 10' ECUs there are some changes in pinout between the two ECUs. 

We name one of the ECU '2004 to 2006' and the other ECU '2006 to 2007'. But have found these year guidelines are not always correct depending in geographical location. One way to know which ECU you need for certain is to follow this:

There are two different Subaru Impreza WRX V10 ECUs available. These are categorised as 2004-2006 2500cc and 2007 2500cc. This maybe slightly misleading as some 2006 vehicles require a 2007 ECU.

It is critical that the correct ECU for the vehicle is installed, failure to install the correct ECU can result in engine component, engine wiring or ECU damage.

The correct ECU can be verified by studying the wiring loom.

If pins A1, A2 and A3 (see pinout section) contain no wires, then the correct ECU required is the 2007 2500cc version. If these pins contain wires, then the correct ECU is the 2004-2006 2500cc version.

V10_connector.thumb.PNG.cd7621e28e5ce2fd

 

In some markets it is also possible to have 2.0L cable driven engine in 2005.

If you can confirm which engine and ECU you have we can then give further advice.

Scott

Share this post


Link to post
Share on other sites

Thanks for the info ,we now have the car in our workshops and have found that it doesnt have any wires in A1,A2 or A3 and has a 2007 ecu .It doesnt have exhaust Avcs either as the customer was lead to believe .

So the only issue is the AC ,if we change the pull up to ON in DIG 3 input  the AC clutch cuts in and everything works .

Any suggestions 

Thanks Dave

 

Share this post


Link to post
Share on other sites

A/C compressor clutch relay is controlled by Aux-Ign 6 on pin C9.

A/C switch input signal is on Digital Input 3, and could be on pin C23 or C24 depending on the jumper position on the bottom board of the ECU.

It sounds like you may not be receiving the signal from the A/C controller. Was the A/C working on the factory ECU?

Scott

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...