Jump to content
interprodave

Turbo Honda blackbird ecu

Recommended Posts

Which would be the best choice of ecu to run and turbo charged honda black bird with the following :-

12 teeth on the crank 3 spikes on the cam 

4 injector ,4 ignition outputs 

Boost control   3 maps 

Launch control with 1 magnetic wheel speed input 

ALS with egr

Thanks Dave

Share this post


Link to post
Share on other sites

How are the teeth spaced on the CAM?

The Monsoon would be the pick I think as that will have enough for what you are after. The next step would be the G4+ Storm.

 

 

Share this post


Link to post
Share on other sites

Thanks Simon,

 to simplify matters would it be better to have a missing tooth on the crank (12-1) and a single spike on cam and where would you suggest these are phased

Dave

Edited by interprodave

Share this post


Link to post
Share on other sites

Hi Dave,

I usually find missing tooth wheels to be less troublesome.  if you go to 12-1, you want the missing tooth to be near either 90°BTDC or 90°ATDC - it doesnt matter which.  The position of the cam tooth is not particularly important you just dont want it to occur at the same time as the missing tooth.

 

Edited by Adamw

Share this post


Link to post
Share on other sites

Thanks for the reply ,sorry for the slow response unfortunately the chassis was delayed .We are experiencing some trigger issues .The engine is fitted with VR cam and crank sensors but runs very rough and shows around 40 degrees of timing scatter also when checked the crank trigger we see a different pattern on our separate scope (please see attached images)

Will be grateful for any advise 

Dave

IMG_3144.JPG

IMG_3143.JPG

scope.jpg

reverse crank.jpg

please find start up cal

nick start.pclr

Share this post


Link to post
Share on other sites

Looking at your file you have the trigger 1 and 2 both set to Optical/Hall sensor type.

From the scope image these need to be set as Reluctor

In the second trigger scope the polarity of the crank signal is incorrect.

 

trig.JPG

Edited by Simon

Share this post


Link to post
Share on other sites

In your post above you have two trigger scopes from a link ecu.  One shows a 36-1 wheel so I dont think that came from your bike.

The other one that shows the 12-1 pattern it shows trigger 1 has been wired with the wrong polarity.   Even though your cool old school "tv screen" shows it opposite I would believe the link trigger scope.

Can you post another triggerscope once you have changed the trigger settings as per Simon's post - I suspect you are going to have to swap wires on the crank sensor too.  

Edited by Adamw

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...