Jump to content
TechDave

[UPDATE] PCLink 5.6.5.3338 Released

Recommended Posts

Good morning everybody,

Last night we released a new PCLink and Firmware, I updated this thread but it didn't stick (weird eh?)

Thanks for your patience with the 5.6.2 to 5.6.5 update-requiring-ECU unlock bug. Thanks Davidv for his work around.

PCLink Version 5.x.x.3338 (DLL Rev 3260) – 15-02-17

Fixes

  • Fixed bug where users updating from 5.6.2 to 5.6.5 were required to enter a factory unlock code.

 

G4+ Firmware Version 5.6.5.3335 – 14-02-17

Changes

  • Add CAN frames to Audi TT mode to support later models.

Fixes

  • DI 3 & 4 pullups now remain enabled after power cycle on Monsoon

 

I'll leave these notes attached because they're still quite relevant to this release:

PCLink version 5.x.x.3289 (DLL Rev 3260) - 22-12-16

New Features

  • Shift + V and Shift + H interpolate the current table selection vertically and horizontally respectively.

Changes

  • Improvements to: CAN window, idle control settings, table axis setup window, parameter selection, connection settings, offline basemap settings.
  • Renamed ‘Value List’ to ‘Logged Value List’ to differentiate it from ‘Runtime Value List’
  • Time plot legend now displays the entire status for the current log file (overlays are still truncated to keep the legend size reasonably small)

Fixes

  • When opening a new log file, time plot zooms all the way out.
  • Fixed a few broken help links.
  • Cal tables 4 to 6 now round Lambda values properly in Japanese. Further improvements to Cal table 4 to 6 settings.
  • Target Gauge now recalls its min and max values better.

Firmware Version 5.6.5.3303 - 28-01-17

New Features

  • Increased the number of Virtual Auxiliaries to 8.
  • Added trigger modes for Suzuki K6A without VVT and Rover K series.

Changes

  • Added user labels to Aux 11-16.
  • DI 11-16 now have GPSpeed option.
  • Added DI 12-16 as input selections for Speed Limit, Anti-lag switch and Gear Sift up/down.
  • Aux 17-20 now accept Virtual Aux as input to mimic GPOutput functionality.
  • Aux switch conditions now accept APS%, Speed DI 11-16, CAN TC and Ignition switch as inputs.
  • 100kbit/s option added to CAN.
  • Added Zeitronix ZT3 lambda calibration.
  • Increased Speedo Out maximum frequency to 4kHz on Aux 1-4 and Aux 17-20.
  • Fuel Pump Prime can now be set to zero seconds.
  • Knock Control sampling has had delay removed to increase sampling window to cylinder spacing minus 5 degrees.
  • Loss of signal from CAN-Lambda sets lambda value to zero and any zero value is removed from Lambda Average.
  • Lambda Average defaults to zero if no wideband sensors are working correctly and CLL is suspended.
  • Closed loop FP Speed now supports positive polarity and a Pump Off duty cycle has been added.
  • Fuel calculation now uses Short Pulse Width Adder table up to 8000rpm.

Fixes

  • MAP Delta on table axis can now be set negative.
  • BMW M3 trigger mode now energises bank 2 injectors on Multi-Point Group mode.
  • OBDII Lambda1 and Lambda 2 equivalence ratios were reversed.
  • Trigger Arming Voltage was not always updated when ECU logging was running at its maximum.
  • Injector Test now always turns injector off even when Injection Mode is off.
  • VVT tables now become visible if CAM Type changed.
  • Dual Fuel Tables Interpolate Between is supported for Traditional Fuel Mode.
  • GPTable allocation could be corrupted in rare situations.
  • Prevented trap if FP-Speed selected on Aux that did not support PWM and PWM control mode selected.
  • Thunder onboard wideband could continue to indicate normal operation even if a fault developed.
  • Closed loop Boost Control now operates on Monsoon after power cycle.

As always, here's how to update your firmware the best way:

Edited by EngineeringDave
new pclink

Share this post


Link to post
Share on other sites

I found idle target trim table was populated with values which could give a few headaches if a file compare wasn't done. 

Thanks Ducie.

I've added this to the firmware list to get looked at.

Share this post


Link to post
Share on other sites

i havnt updated to the new version yet but im having issues on windows 8 that pclink crashes if i let my laptop sleep then start it back up? loosing a lot of logfiles :(

Thanks, I'm aware of this issue, it is marked as high priority and I've been working on a solution.

Share this post


Link to post
Share on other sites

Installed new PClink, now plugging into ECU it says that my ECU needs an unlock code.

Thoughts? Was working fine yesterday on previous version, have restarted ECU and laptop.

Using a red G4+ xtreme.

Ahhh  sorted it. Had to factory reset the ECU then load new firmware on it,then my basemap back on it.

Edited by Davidv

Share this post


Link to post
Share on other sites

The software wont install on win 10, tried compatibility mode in win 7 &8.

Untitled.jpg

Can you give us a bit more info on the system you are using go to system information > system summary

Share this post


Link to post
Share on other sites

I installed this update.. 

I went to the track today and when changing gears and going full throttle again it back fired had to back off.. Also sometimes it would die on me would have to re start it. 

Tried to download the ecu log file and it was not anything of use basically didn't record for some reason even though it's supposed to above 3000rpm.

The car was perfect before the only other thing I did since then was to recirculate the blow off valve back into intake pipe before turbo. 

Any ideas on this if it's somehow related? 

 

Cheers

 

Share this post


Link to post
Share on other sites

I'd like to add when the engine lost power the tacho was stuck and wasn't moving. 

After stopping and doing a power cycle it was fine till. The next time 

Share this post


Link to post
Share on other sites

I installed this update.. 

I went to the track today and when changing gears and going full throttle again it back fired had to back off.. Also sometimes it would die on me would have to re start it. 

Tried to download the ecu log file and it was not anything of use basically didn't record for some reason even though it's supposed to above 3000rpm.

The car was perfect before the only other thing I did since then was to recirculate the blow off valve back into intake pipe before turbo. 

Any ideas on this if it's somehow related? 

 

Cheers

 

Hi Muzzytt,

This release has been circulating a while now and we havent had any major show stoppers reported.  There is a problem with the dual fuel table when set to overlay mode so if are using that feature then this may be your problem.  You can downgrade firmware if you believe there is a problem.

Can you send me a copy of your .pclr so I can take a quick look.  It would be good if you have a copy from before the upgrade too.  Send to: NAjJcZt.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×