Jump to content
Highlift

Slow reacting

Recommended Posts

Why is it when a large block of cells in say a fuel or ignition table is selected and then incremented up or down does it take for ever for the change to take effect in the ecu?

Is this due to the slow serial connection to the laptop or just slow code?

It does make tuning frustrating, surely other people have noticed this.

Share this post


Link to post
Share on other sites

My tuning laptop is nothing special, an old 32bit i3, with integrated graphics, I have never noticed any slow behavior like this although it is rare for me to need to adjust a whole table very often.  So I just tested this for myself - I selected the whole fuel table and tried bumping it up and down using the Q & A keys, I also tried by manually typing in a new value and also doing "maths" to the whole table, in all cases the change is almost instant.  This was with an engine running and PC logging running in the background at the same time.

On my desktop PC it has a AMD processor with built in graphics and I have found that is a bit slower when running many channels of logging live at the same time.  In that case though it seems more like a graphics "drawing" issue, the ecu updates instantly but the screen lags a little.  It would still only be a fraction of a second though? 

Share this post


Link to post
Share on other sites

It doesn't have to be the whole table, just a large block of cells, the larger the block the worse it gets. Yes the "maths" functions work ok, it is just with the q&a increment keys. Give it 3 or 4 clicks on the key & the table freezes up while things are happening, the delay can be several seconds. The delay is also reflected in the change in lambda.

I will see if I can arrange a video demonstrating it.

Share this post


Link to post
Share on other sites

For completeness sake I just dug out my weakest PC.  It is a Dell venue 8 pro tablet, I think it has an Atom processor and it is pathetic in terms of processing power, it only has 2Gb ram and can take like 30 seconds to open up some web pages...  To further injure its performance I am connected to the ECU via a Chinese junk OTG USB cable.

Here is a short video of me messing around with the fuel table - initially with Q&A keys, then directly entered values, then math functions.  I wasn't sure how I to show key presses in a video but I think it still shows it is responsive?  It seems quite acceptable to me, I would certainly have no trouble tuning with it.

https://adam-linkecu.tinytake.com/sf/MTU2OTI2N181MzkxMTk1

Share this post


Link to post
Share on other sites

I have to say, lately i'm having some issues to. but only when i just connect to the ecu.

SO i put in the usb cable, press F3 and then i have to wait lets say 2 minutes, before everything stabilizes en stops freezing, after this, everything works flawlessly

Share this post


Link to post
Share on other sites

I'm in the same boat as the guys experiencing the lag.

Whether it is upon first connection or when making large block changes.

Only work around that i have found is knowing that the fault is there and being patient.  

I have mentioned this in several facets ever since they rolled out G4+.  With G4 none of these issues were present.

Pretty sure it is the software itself not the PC, as i can do the same process in G4 and G4+ on the same machine and on the G4+ software shows the lag.

 

Share this post


Link to post
Share on other sites

I have a similar thing.

I have a 6 month old Dell laptop with an i3, 8GB RAM, SSD and Intel onboard graphics running Windows 10 which lags, moving between windows, changing settings etc. Then it will be ok for a minute or two then lag again. Its fine not being connected to the ECU. This laptop i rebuilt specifically for tuning as its smaller than the Lenovo and has long battery life.

I have a slightly older laptop Lenovo i7, 8gb RAM, SSD and intel onboard again which works flawlessly. I have used other laptops too which have no issues. 

I would think this is probably something to do with USB/Windows 10 more than anything else.

 

Share this post


Link to post
Share on other sites

I have just done some testing on my Dell laptop which only has 2 USB ports. One is USB 3 (Blue) and the other is USB 2 (Black). I have been using the left USB 3 port as it was easier to plug in while in the car. I swapped it over to the USB 2 port on the other side and i now no longer have any lag what so ever in the software. It was really bad before,.

I have found this the case many times in Windows 7 and Windows 10. A lot of devices just dont work well in a USB 3 port unless they are USB 3 themselves. Most likely a driver issue.

Check your laptops and see which port you are using as it may be the same case for you too.

Share this post


Link to post
Share on other sites

Hi All, 

I thought I better post that we arent ignoring you, we have been monitoring this thread and the other similar subject somewhere further down.

Interesting comment about the USB3, that's one I hadnt considered.  All my PC's are USB2.  For whatever reason we dont see this lag inhouse on any of our PC's - they are mostly all Win 10.  Note the slow response for the first 10seconds or so after initial connection is normal, but once that is done it should be responsive and nice to use.  I think my wife has a laptop with USB3 ports so I will test that in the weekend.

Can I get all that have posted they are having a problem to also post up the info below so we can see if any common themes start to form:

Windows version?  32 or 64bit?  Graphics adapter?  USB2 or USB3 ports?  If using Win 8 or 10 is the display scaling set to 100%?

Share this post


Link to post
Share on other sites

Im having the same issue with a very fast laptop used daily sounds like a usb driver issue.  But this is very frustrating as this doesn't happen with other tuning software I use daily 

Share this post


Link to post
Share on other sites

We updated PCLink last week, but had to take it down again after some bug reports, should be back up soon.

I found my laptop slow too when I first got it, a driver update fixed it. Make sure to get the proper drivers from the vendor.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×