Jump to content
MarcD

MX5 Fuel pump always on

Recommended Posts

have jumpered the AFM connector to bypass the fuel pump switch in the now defunct AFM

Fuel pump now runs with key in run position, before engine on. the cranking circuit runs fine too.

any tips on how to configure in pcLink or rewire that cutout switch so that fuel pump only runs when engine is running? 

thanks!

Marc

 

Share this post


Link to post
Share on other sites

I just took a look at the schematics for that car.  It looks to me like the "LT GRN" wire at the AFM connector controls the FP relay.  So if that is jumpered to gnd then the FP will run all the time as you have found.  I suggest instead you run a new wire, connecting the LT GRN wire to pin 17 on the ECU header.  Pin 17 is controlled by Aux 5 and is already assigned as fuel pump in the ECU so just connecting it should be all you need to do and it will work properly without any further config.

Share this post


Link to post
Share on other sites

finally got round to this.

so for closure.... there are no terminals inside the ECU connector on pin 17 (on a number of them actually - any idea where i can get them from for future?)

so, as I am not using the purge solenoid, yellow/red wire into pin 15 / Aux7, I used this. 

configured as Fuel Pump. working perfectly.

thanks Adam

 

 

Share this post


Link to post
Share on other sites

The terminals for the NA/NB MX5 are the same as we used for the G3 series so we are able to supply via the dealers if you require.

Share this post


Link to post
Share on other sites

The small pins on this connector would take the TE Multilock 040 terminals and the big pins would use the Multilock 070.  You should be able to find them at places like Mouser.com or digikey.com

Share this post


Link to post
Share on other sites

closing this out for the last time!

for MX5 NA 1989 1.6

I got a heap of those connectors from Mouser.

I rewired fuel pump to be on Aux 5.

I wired the purge solenoid back up to Aux 7 and now use the purge solenoid as a cold start air device - small air filter on one opening, other to the inlet manifold, and solenoid activated below 40C. works a treat!

 

also had the separate questions around the AF gauge and where to tap the 12V feed from to only be on when engine is running. Wanted this as when downloading big ECU logs, or fiddling with link, the ECU needs to be on for a while but not engine running, which meant in the old configuration, the AF sensor heater was also on - not good for longevity. Turns out the correct wire is the Blue/Red on the fuel pump relay (yellow re;ay and connector) up above the accelerator.

hope this helps someone else in future!

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...