Jump to content
Cozcorners

Dashes... to suit thunder ecu

Recommended Posts

Hey guys,

I'm in the market to buy a data dash, since i want warnings, data displayed etc.

Logging isnt so important as ill be logging everything with the thunder ecu, so if i need to see something i can always load up logging from the ecu.

My main concern is suitability with the ecu I'm running... can anyone suggest or confirm which of the dashes they used that worked 100% with no issue's and can accept the links protocol? I want to make it a simple mod and something easy to understand (if that's possible lol).

I dont want to buy something just to find out it doesnt support my ecu, or the data seen by the dash becomes odd and unreliable because it doesnt understand it etc.

 

The main ones I'm liking is Aim Mxl2, aim mxs and the just released AEM cd-7. I like the new motecs like c125 even tho maybe a bit small? But am confused with all the features that need to be enabled to have the same capabilities as the aboves? . just confusing to someone like me.. 

Anyway... opinions and advises appreciated.

Edited by Cozcorners

Share this post


Link to post
Share on other sites

Any of those listed work well, at present there are a few bugs in the new AIM's CAN but nothing major and we can work around it with a slightly modified CAN stream (oil pressure reads 1/10 actual for instance.)  I personally like the AEM as all screens are fully customisable, with the MXS you can display whatever info you want but you are limited to a few preconfigured layouts.

The Plex SDM's are worth a look too.

Share this post


Link to post
Share on other sites

Hi Adam, I also have just installed the Aim MXS Strada to a Fury, using Can 2 to run the dash, I am having the issue of the oil pressure reading 1/10 what ecu is seeing? Is there a fix for this? Cheers Tim

Share this post


Link to post
Share on other sites

Hi Adam, I also have just installed the Aim MXS Strada to a Fury, using Can 2 to run the dash, I am having the issue of the oil pressure reading 1/10 what ecu is seeing? Is there a fix for this? Cheers Tim

Hi Tim,

I have had another user report that Lambda/AFR is displayed incorrectly too.  Attached below is a CAN stream to try.

Instructions:
Set up the CAN mode tab like below. Mode=User defined/1Mbit/Channel1 = transmit user stream1/format normal/ID=1000/rate =20Hz.

g7o6Uj9.png

 

Then go to the streams tab, select stream 1, then click "load stream", navigate to the new stream file "AIM Press x 10 Lam x 0.1.lcs" Click apply, ok then do a ECU store. 

e7yKl0m.png

AIM Press x 10 Lam x 0.1.lcs

Share this post


Link to post
Share on other sites

Hello, old thread resurrection!

i am also having the issue of the pressures reading 10% of their actual values. 

I downloaded the link you put and loaded the stream, but it hasn’t worked. 

One thing I noticed is that when you load the stream it doesn’t apprear in the box like your screen shot shows, however stream one on the left now has a drop down box, whereas it didn’t before. 

 

Thanks 

Share this post


Link to post
Share on other sites
13 hours ago, NathanFreke said:

One thing I noticed is that when you load the stream it doesn’t apprear in the box like your screen shot shows, however stream one on the left now has a drop down box, whereas it didn’t before. 

Just in case you are doing something wrong, here is a quick video showing me doing it:  https://1drv.ms/v/s!AiYbYlZQuRHPmUKHSMtEXH5K7SU4

Also, re-download the .lcs file that I have attached to this post as I have fixed another incorrect reading channel since that last one.

AIM Press x 10 Lam x 0.1.lcs

Share this post


Link to post
Share on other sites

Hello, I wonder if you can help here... the AIM MXS is displaying the CAN now, but it’s showing the fuel pressure as a minus figure. 

 

Could i I get some help to correct this?

 

Thank you 

Share this post


Link to post
Share on other sites
On 12/21/2017 at 11:42 PM, Adamw said:

Just in case you are doing something wrong, here is a quick video showing me doing it:  https://1drv.ms/v/s!AiYbYlZQuRHPmUKHSMtEXH5K7SU4

Also, re-download the .lcs file that I have attached to this post as I have fixed another incorrect reading channel since that last one.

AIM Press x 10 Lam x 0.1.lcs

Is there another location for the video linked above? its no longer available through the current link.

Share this post


Link to post
Share on other sites
3 hours ago, Narvarr said:

Is there another location for the video linked above? its no longer available through the current link.

What are you trying to do?  All of the discrepancies that this CAN stream was used to correct have been fixed in the Aim firmware or the new MXS stream in the ecu.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...