Jump to content
krohelm

VE way too high

Recommended Posts

On a Toyota 4age 20v Blacktop with a G4+ Monsoon, factory injectors.  The engine runs well, but the VE table seems really strange.

I observe full throttle VE over 130% in places (5500-6000rpm).

I expect VE to top out closer to 100%, maybe 110% tops?  I have:

  • Installed a Turbosmart fuel pressure regulator.
  • Installed Honeywell fuel pressure sensor.
  • Sent injectors to Witch Hunter Performance, cleaned & serviced, measured ~310cc/min at 300kpa.
  • Set base fuel pressure to ~305kpa.  Manifold differential fuel pressure stays within about 2% of that.

I went looking for a data problem when I noticed my VE's were up above 120% based on injector information I gleaned from the Internet.  After gathering data and ensuring my injectors are working perfectly, I'm now measuring beyond 130%!  Take a peek at my configuration, what seems wrong in here?

csv log attached, as I can't export an .llg zoom snapshot and my log is just over the attachment limit.

ve_too_high_question.pclr

log.csv

Share this post


Link to post
Share on other sites

I have IAT correction on because of the PCLink docs:

Note:  It is recommended that all applications use intake temperature correction.  IAT Correction requires that an intake temperature sensor be installed and an Analog Temperature Input be configured correctly as Inlet Air Temp. 

Rereading the docs for Charge Temp Correction makes it very clear that this is not the right setup unless I know what I'm doing (I don't, :-)).  CTC ideally achieves IAT correction based on my current understanding, so bare IAT should not normally be required.  Thank you for taking the time to look at my pclr!

I don't have a spare injector, no.  Would have been smart to get dead times yesterday before reinstalling them...  I'll try to come up with one.

edit: Maybe I'll give this a try:  https://www.miataturbo.net/ecus-tuning-54/how-find-your-injector-dead-time-56061/

Share this post


Link to post
Share on other sites

Also do you a pic and part number of the fuel pressure sensor? Calibration table looks different to the Honeywell sensors I use.

 

Also what map sensor are u using?

Edited by Ducie54
Added

Share this post


Link to post
Share on other sites

This is the fuel pressure sensor I'm using:  http://www.mouser.com/search/ProductDetail.aspx?r=785-PX3AN2BS100PAAAX

Should be linear, absolute vacuum referenced, 0.5v-4.5v vacuum-100psi.  If you have a different understanding, I'd be very happy to hear it!

 

I'm using the built in Monsoon MAP sensor.

 

edit:

After doing the miataturbo dead time calculation and removing the IAT compensation table, my idle VE sits at 51.6%.  This seems more in-line with reality than the 76% it was before.  Should tame the table a little across the board.  Thanks for the thoughts Ducie54, I'm still very interested in your feedback on the honeywell sensor I'm using.

Edited by krohelm
Didn't want to make a double post.

Share this post


Link to post
Share on other sites

Use cal tables 4,5,6 for linear sensors. Your current settings are already linear and correct but it hard to visually see unless you do an interpolation over the top. Once you have your CTC setup you should also be able to Zero out the warm up enrichment table. I only use IAT correction as extra at idle and high Air temp 

honeywell_100psi.thumb.png.22e9271e3cc3e 

 

Edited by Ducie54
more to add

Share this post


Link to post
Share on other sites

Nice!  4, 5, 6 are much simpler.  I thought too hard on that one.

I don't know how to dial in Charge Temp Correction, but I've zeroed out the warmup table and the post start table.  CTC should handle all this once I figure it out, and what's in the table is close enough to keep it running while I work on it.

Thanks Ducie, I've learned a lot from what you've shared.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...