Jump to content
wasted talent

CAN dash setup

Recommended Posts

Solved.

Trying to set up a plex uSDM100 via CAN to g4+ ecu.

The uSDM has Link settings pre loaded but cannot figure out what the ecu end should be set to.

Anybody got one working that may have overcome this problem simply?

Edited by wasted talent

Share this post


Link to post
Share on other sites
On 1/10/2018 at 9:12 PM, ClintBHP said:

Try this: Select the correct CAN Bus and Enable User Defined Mode and Transmit Generic Dash at 1Mbs on CAN ID 1000

 

 

Done it ! It works but suddenly i lost communication with ECU.  The other thing i am dealing now when i have the DASH connected i cant connect to the ECU. 

Share this post


Link to post
Share on other sites
17 minutes ago, Demetris said:

Done it ! It works but suddenly i lost communication with ECU.  The other thing i am dealing now when i have the DASH connected i cant connect to the ECU. 

See this thread, sounds like you have the same problem with some wires connected to the RS232 pins.

http://forums.linkecu.com/topic/7624-can-port-connection-issues-and-jzx110-ethrottle/

 

Share this post


Link to post
Share on other sites
5 hours ago, Simon said:

Yep

 

Do it and looks that its works normally ! 

 Now the problem i am dealing is losing communication with dash :(   I open switch everything looks to work normal for 1-2 minutes and then suddenly no communication and get can-bus error.  Anything to do about cables or length of cables ? 

 

Share this post


Link to post
Share on other sites

What are the errors exactly, is the Dash terminated?

If you put a multi meter over the can bus while everything is turned off what is the resistance. 

Are the 2 CAN wires twisted together at a rate of about 1 twist per inch?

Share this post


Link to post
Share on other sites
5 minutes ago, ClintBHP said:

What are the errors exactly, is the Dash terminated? just lost communication and get can-bus erros .

image.png.3fbe89ac9c8714e0d96cf4affeabf061.png

5 minutes ago, ClintBHP said:

If you put a multi meter over the can bus while everything is turned off what is the resistance.   I can check it today and come back to you 

Are the 2 CAN wires twisted together at a rate of about 1 twist per inch? The dash cable is twisted. Dash cables YES. connect to ECU with CANPCB cable and CANF plug as LINK recomantation.  ( from what i see the CANPCB cable looks not to be twisted- maybe i am wrong but this is how i see the cable ) 

 

Share this post


Link to post
Share on other sites

The Plex dashes have the termination resistor built in so you should be ok there.  Correct that the CANPCB cable is not twisted but I have never seen that cause a problem, it is only ~150mm long.  

Can you attach your .pclr file so I can take a quick look at your settings.

Share this post


Link to post
Share on other sites
29 minutes ago, Adamw said:

The Plex dashes have the termination resistor built in so you should be ok there.  Correct that the CANPCB cable is not twisted but I have never seen that cause a problem, it is only ~150mm long.  

Can you attach your .pclr file so I can take a quick look at your settings.

this is the file i have on the car. I also contact plex support and they will see my case later on today. And i will come back with their findings. 

stockcan enable geardetection on.pclr

Share this post


Link to post
Share on other sites
4 hours ago, Demetris said:

image.png.3fbe89ac9c8714e0d96cf4affeabf061.png

 

You are transmitting, your transmit counter has hit 128 and not gone up more this indicates the Plex is not sending an Acknowledgement (or cant see the transmit) 

Share this post


Link to post
Share on other sites
28 minutes ago, ClintBHP said:

You are transmitting, your transmit counter has hit 128 and not gone up more this indicates the Plex is not sending an Acknowledgement (or cant see the transmit) 

Ok, so maybe its too long the cable and i lost data ?bcs as i say some times the dash works normal for 1-2 minutes before i get the error.   As i mention above i will speak tonight with plex and see what they will say about it ! 

Share this post


Link to post
Share on other sites
13 hours ago, Adamw said:

The Plex dashes have the termination resistor built in so you should be ok there.  Correct that the CANPCB cable is not twisted but I have never seen that cause a problem, it is only ~150mm long.  

Can you attach your .pclr file so I can take a quick look at your settings.

I had some troubles with CAN not working right with the LINK CAN-Dash cable in past. 

Adam if i remember right the CAN Dash cable has a resister buil it, isnt'it? 

I would try a twisted cable from ECU to the Dash. I installed already alot of Plex uSDM 100 and 102 dashes. Only problems o had was firmware updating the Plex doesn't work right sometimes and you have to load a older firmware first anf then lates again. 

Besides, you can do some smart things with Math channels and custome CAN.

Share this post


Link to post
Share on other sites

No resistor in the candash cable but it does have the TX and RX serial wires connected which will cause issues with the PC coms when connected.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×