Jump to content
Barnesy

Help with wiring

Recommended Posts

Hi

I am about to take the link G4 out of me 2004 STI.

The previous owner had the ECU put in.

My question is:

  • There is a harness that comes out the back of the ECU (see attached photo) the only 2 wires being used is a green and a white one (marked in pic), what would these wires be used for?
  • Is the harness an expansion harness?

Any help is really appreciated

 

Cheers,

 

Scott

LINK ECU 2.jpg

Share this post


Link to post
Share on other sites

It is an expansion harness. It could be a number things as the green wire will be ground and the white wire is a AN volt input. The volt in put could be used for a number of functions.

Seems a shame to be removing the ECU

Share this post


Link to post
Share on other sites

I know, the engine let go and the engine builder/tuner I use doesn't tune Link.

So all I can do I suppose is follow it. Correct?

Could it be input from AFR? OR Any ideas what it could typically be?

Cheers,

 

Scott

 

Share this post


Link to post
Share on other sites

It looks like the ecu tuning cable is there - could you connect to the ecu and see what the AN volt input is set up as?

Share this post


Link to post
Share on other sites
12 minutes ago, CamB said:

It looks like the ecu tuning cable is there - could you connect to the ecu and see what the AN volt input is set up as?

I will give it a go when I get home?

Really don't know what to look for after I plug it in though.

Will get back to you tonight if you don't mind.

Share this post


Link to post
Share on other sites

If you save a copy of the file and upload it here, someone can look for you. 

Or click on the "ECU Settings" tab on the left in PCLink and look at the list of Analog Inputs for whatever is numbered AN Volt 5 or higher. You could take a screenshot.

Share this post


Link to post
Share on other sites

Going off the map supplied you have a G4 Storm based plugin which in theory has no free inputs on the XS connector.

I'm assuming you have the 2L cable throttle model not the 2.5L ethrottle

Share this post


Link to post
Share on other sites
32 minutes ago, Simon said:

Going off the map supplied you have a G4 Storm based plugin which in theory has no free inputs on the XS connector.

I'm assuming you have the 2L cable throttle model not the 2.5L ethrottle

Yes that's right 2L cable throttle.

Do you have any idea what the green and white wires that are connected are for?

 

Share this post


Link to post
Share on other sites
3 hours ago, Simon said:

Going off the map supplied you have a G4 Storm based plugin which in theory has no free inputs on the XS connector.

The help file says there is, for AN Volt 6 only?

Either way - Barnsey - the pcl file does not appear to use the input. Perhaps you don't need to worry about it?

Share this post


Link to post
Share on other sites
3 minutes ago, CamB said:

The help file says there is, for AN Volt 6 only?

Either way - Barnsey - the pcl file does not appear to use the input. Perhaps you don't need to worry about it?

Do you think that it may not have shown it being used because the engine wasn't running?

Sorry for the questions really don't know much about ECU's.

Cheers 

Share this post


Link to post
Share on other sites
45 minutes ago, Adamw said:

Does it even matter what it is for?  If you are removing the ecu just chop the wire and leave it there.

Hmm you do have a very good point there.

I suppose its not something the standard ECU uses.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×