Jump to content
Summer Ng

Daihatsu L700 VVti Wiring Problem

Recommended Posts

HI every one... I'm the new one In LInk ECU. My EJ-VE B.O.T Twim Cam VVt-i 1000CC

I got a problem In Wiring job... First Is the ISC Problem. Original Hving a 3 Pin Solonied ISC... 

In Manual show that 3 Pin Solonied must wired in the AUX 1 & 2.. But my engine have VVti- also,

but the side VVti Solonied Need To Wried In The line with 1 AUX & 1 Digital.. I Hv No ideal for it.

some more My EJ-VE Engine just hv ONE VVti Pully sitting at the Inlet Cam with one Cam Position sensor..

my Crank trigger are sitting at the Cam Pully For Customize tooth 24-1. 

i can unplug the cam position sensor to start my engine... Engine is already start up RPM, Timing all settle..

pls gv a hand here thank you... 

 

Share this post


Link to post
Share on other sites

You can use any aux 1-5 for the vvt solenoid.

I also suspect your idle valve may actually not be what we call a “3 wire” type.  I think it maybe like the Subaru type that has 12V, ground, & signal?  Have you got any info about it or a wiring diagram?

if you have 24-1 crank and 1 tooth on cam then it should start and run, just leave the vvt solenoid unplugged.

I don’t think you will be able to get vvt to work if you have changed to a 24-1 crank trigger.

Share this post


Link to post
Share on other sites

Hi Adam thanks for reply..... I think is same as Subaru. (picture below)..  if like Subaru ISC means no consider is 3 pin ISC is it?  ya my car was started but I need the vvt-I system too.... I got an inlet cam angel position sensor for my original ECU.... Can Adam pls tell me more. why 24-1 tooth cannot be support VVT-I system? I can get more data of my engine or original wire u need....  

Can u pls show about VVti solonied wiring insert and cam angle sensor...

PLS CORRECT ME IF I WAS WRONG.

VVTI solonied (+) AUX 1

VVTI solonied (-) place to ground

cam angel sensor  Place to Digital Input

another to the sensor ground 

i

 

 

Share this post


Link to post
Share on other sites
1 hour ago, Summer Ng said:

Hi Adam thanks for reply..... I think is same as Subaru. (picture below)..  if like Subaru ISC means no consider is 3 pin ISC is it?  ya my car was started but I need the vvt-I system too.... I got an inlet cam angel position sensor for my original ECU.... Can Adam pls tell me more. why 24-1 tooth cannot be support VVT-I system? I can get more data of my engine or original wire u need....  

Can u pls show about VVti solonied wiring insert and cam angle sensor...

PLS CORRECT ME IF I WAS WRONG.

VVTI solonied (+) AUX 1

VVTI solonied (-) place to ground

cam angel sensor  Place to Digital Input

another to the sensor ground 

i

 

IMG_0943.JPG

That is for sure a Subaru ISCV. The Map sensor next to it looks Subaru as well.  Honestly the pic looks like it is a Subaru.

VVT solenoid gets +12v from relay and ground from ecu Aux.

If it is just one cam angle sensor, the signal will go to trig 2.  If it is just a 2 wire mag sensor the neg lead will go to Shd/Gnd right next to trig 2 on the ecu connector.

 

Share this post


Link to post
Share on other sites

Thank you for yr advise Brad Burnett 

act I was in house I just capture pic from web my engine  ISC is same like this 

any where thanks for giving a hand for help 

Share this post


Link to post
Share on other sites

Thank you for yr advise Brad Burnett 

act I was in house I just capture pic from web my engine  ISC is same like this 

any where thanks for giving a hand for help 

but why inside manual VVT-I system announce that Need to wired at same number of  AUX and Digital ?

i really don't understand 

Share this post


Link to post
Share on other sites

Thank you Mr Brad Burnett... 

Air Cond was not working 

I wired AC switch to digital 3 

mgn clutch to Ignation four and switched to A/C clutch but not working.... 

Pls gv me a hand here... 

 

Share this post


Link to post
Share on other sites

Which page need to attach copy? 

Air Cond was not working 

I wired AC switch to digital 3 

mgn clutch to Ignation four and switched to A/C clutch but not working.... 

Pls gv me a hand here... 

 

 

Share this post


Link to post
Share on other sites

The bottom screenshot above shows that ignition 4 is on when DI3 is on, so the ECU seems to be doing what it’s meant to be.  If your AC clutch is not engaging when PCLink shows AI4 is on then you likely have a wiring issue.

You can set AI4 function to “Test(on)” mode to check your wiring.

Share this post


Link to post
Share on other sites

Mr Adam just one more time for checking wiring is totally no issue.. now I try to Put the AC mgt signal to AUX5 already no problem... is that I didn’t do setup at Ignation output AUX? 

Another question here (picture below) this kind of ISC in my car it cannot Control by ECU 

this ISC is 12v, signal, ground 

is that I mess up the diagram... 

 

Share this post


Link to post
Share on other sites
22 hours ago, Summer Ng said:

Another question here (picture below) this kind of ISC in my car it cannot Control by ECU 

this ISC is 12v, signal, ground 

This should be no problem to control.  12V & Ground, then any spare aux 1-4 to the "signal" pin.  I dont have a pinout for that valve so you will have to work that out yourself.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×