Jump to content
Superstock22s

Innovate MTX-L wideband to link G4+Atom

Recommended Posts

You can not only use it for data logging but auto tune function too.

Use the 0-5v output from the innovate and put that on a free AnVolt input on the Link.  Set this input to Lambda, there is a Innovative LM1 Calibration in the drop down list but check the calibration has not changed by comparing the Innovative LM1 manual with your MTX-L manual.

If it has changed then choose one of the simple cal tables, as the innovate has a linear output and set the calibration according to the innovate manual.

Share this post


Link to post
Share on other sites

A couple of extra tips for the MTX-L...

Connect the innovate yellow wire to any spare Link analog input.  

The MTX doesnt have a dedicated analog ground so this will often cause a large and variable ground offset if grounded to the wrong location.  The Innovate manual suggests grounding to the negative battery post but I would suggest the engine block instead.

The "innovate LC1" calibration in the PCLink software is the correct one to choose (MTX is the same).

Share this post


Link to post
Share on other sites

Im not sure you mean autotune, I think you may mean closed loop Lambda Control which is under Fuel - Closed Loop Lambda

Quicktune (Autotune) is on F10 but thats a tuning aid, you will need to set your AFR Target table up first. Reading all the help on this is a must before you do anything

 

Share this post


Link to post
Share on other sites

OK Thanks for that but my loom has the wires removed for the items i want to now log.

The Atom plug header pin out which wires  do i need to reinstall for oil pressure,oil temp,water temp ,and hook up MTX-L gauge?

Sorry for dumbness again all new to me.

Brent

Share this post


Link to post
Share on other sites
41 minutes ago, Superstock22s said:

OK Thanks for that but my loom has the wires removed for the items i want to now log.

The Atom plug header pin out which wires  do i need to reinstall for oil pressure,oil temp,water temp ,and hook up MTX-L gauge?

Sorry for dumbness again all new to me.

Brent

You are limited on the Atom to 3 Analogue Inputs, AnVolt1 on Pin 17, AnVolt2 on Pin 22 and Anvolt3 on pin 33

However you are likely to have things already on these like throttle position & possibly a Map sensor.

You can use any of these if spare.

Share this post


Link to post
Share on other sites

Sorry should have mentioned no injection running 4bbl Carburetor so only output Rpm correct?

That was the only wire from loom and a power wire when i got it to install.

It also had the water temp one but i havent hooked that up yet didnt fit my sensor.

Share this post


Link to post
Share on other sites

Ok

Does this sound right

Innovate MTX-L yellow wire  goes to pin 17/An Volt 1 for the wideband?   It has no Brown wire.

Oil Pressure yellow/black wire to pin 33 /An Volt 3?

Oil Temperature yellow/brown wire to pin 16/Temp 2?

And a green sensor ground wire pin 7/Sheild/Ground to each of the oil temp and pressure switches?

Water temp one was already wired into temp 1 and a green wire.

 Let me know if this looks right.

Do i then need to go into ecu and turn these things on or do they come on automatically?

Share this post


Link to post
Share on other sites
7 hours ago, Superstock22s said:

Innovate MTX-L yellow wire  goes to pin 17/An Volt 1 for the wideband?   It has no Brown wire.

Correct.  Make sure the MTX black wire is grounded on the engine block.

 

7 hours ago, Superstock22s said:

Oil Pressure yellow/black wire to pin 33 /An Volt 3?

We need to know what type of oil press sensor you have.  Is it a 2 or 3 wire?  part number?

 

7 hours ago, Superstock22s said:

And a green sensor ground wire pin 7/Sheild/Ground to each of the oil temp and pressure switches?

Correct.

 

7 hours ago, Superstock22s said:

Do i then need to go into ecu and turn these things on or do they come on automatically?

Yes it will all need to be setup with correct calibrations etc in the software.  Give us some more info about what temp and pressure sensors you have and I will post a couple of pics to help.

Share this post


Link to post
Share on other sites
10 minutes ago, Superstock22s said:

3 pin oil pressure sensor

So the wires to go with oil pressure are a +5v , green shield ground, signal wires ?

Correct.  The Signal wire goes to any analog input.  I will post a pic below of how the set up looks in PC Link.

qZaO0HI.png

rXXRXgm.png

 

For the temp sensors, one pin to ground (green), the other to either of the AN Temp 1/2 pins.

Set up looks like below.  (both sensors use the Std Bosch NTC calibration)

eyhbTFT.png

Share this post


Link to post
Share on other sites

Hi

Please have a read and if im wrong or anyone has a idea please share my question is ive used both my Temp pins for the ECT pin #15, IAT pin #16 sensors but want to run oil temp also.

.I read somewhere i can use the AN Volt 2 pin#22 as a signal and a +5v pin#32 to run Oil temp sensor  It also said i have to use a 1k ohm External Pull up Resistor in the +5v wire before the sensor does this sound correct?

I'll list how i'm wiring bits up please share your thoughts as im green to this and its my first loom, i do have a loom already so will follow that for the ignition wasted spark setup  just doesn't have all the other stuff wired into it.

The Engine is a naturally Aspirated Toyota 1uz VVTI V8 running a  4BBL Holley Xp E85 Carburettor

If someone has a wiring diagram of plug pinout to sensors would be great for future. 

ECT Sensor - #15 pin Temp 1 Yellow wire AND Green wire #24 pin Gnd Out.

IAT Sensor - #16 pin Temp 2  Yellow Brown wire AND Green wire #24 pin Gnd Out.

MTX-L Gauge Yellow 0-5v wire to #33 pin AN Volt 3 Yellow Black wire.

OP Sensor -  #17 pin AN Volt 1 Yellow /Blue wire AND  #32 pin +5v Red/Blue wire AND  #24 pin Gnd Out Green wire

OT Sensor- #22 pin AN Volt 2 White/Brown wire AND #32 pin +5v Red/Blue Wire with a 1k ohm External pull up resistor? Or is there another way?

Cheers Brent

 

 

 

 

Share this post


Link to post
Share on other sites
17 hours ago, Superstock22s said:

If someone has a wiring diagram of plug pinout to sensors would be great for future. 

ECT Sensor - #15 pin Temp 1 Yellow wire AND Green wire #24 pin Gnd Out.

IAT Sensor - #16 pin Temp 2  Yellow Brown wire AND Green wire #24 pin Gnd Out.

MTX-L Gauge Yellow 0-5v wire to #33 pin AN Volt 3 Yellow Black wire.

OP Sensor -  #17 pin AN Volt 1 Yellow /Blue wire AND  #32 pin +5v Red/Blue wire AND  #24 pin Gnd Out Green wire

2

Yes all that sounds correct.

 

17 hours ago, Superstock22s said:

OT Sensor- #22 pin AN Volt 2 White/Brown wire AND #32 pin +5v Red/Blue Wire with a 1k ohm External pull up resistor? Or is there another way?

As per below.

fIZ5yfH.png

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...