Jump to content
Fraser

Thunder e-throttle closed-loop idle (now resolved)

Recommended Posts

Hi folks.

First time Link user here and ive had no issues tuning with it so far.  Trying to polish up the details now but i'm really struggling to get the closed loop idle control working after so many attempts.

'Idle status' always shows 'speed NOT selected'

The ethrottle target is always 'table 1' surely this should change to ethrottle target at some point?

The ethrottle target table 1 is set to '0' at closed throttle and base idle position is '2.5' to give an idle speed of 1k rpm.

No amount of increasing or reducing the error by altering the idle setpoint will make it respond or 'control' 

All it will do is perform a % increase when the coolat fan comes on, and it jumps to this setting with no issues. 

How does it know whether or not to look at table 1 in an idle condition?

Would uploading a short log file help work out whats going on or are there specific settings i should check?

The help file doesnt have a lot of detail on this topic.

Cheers!

Share this post


Link to post
Share on other sites

To fix the "speed not selected message", Under chassis and body you need to go into speed sources and set driven wheel speed source to something relevant - probably LR wheel speed in an RWD car with a gearbox based speed sensor.

Share this post


Link to post
Share on other sites

Thanks for the reply. Ive not selected a drive speed lockout so i assumed the road speed was not required.

Surely i dont need to install road speed feedback to get it to idle?

Share this post


Link to post
Share on other sites
14 hours ago, Fraser said:

Would uploading a short log file help work out whats going on

I think a short log and a copy of your map will be very helpful in seeing where the problem may lay.

 

 

Share this post


Link to post
Share on other sites

Hi Fraser,

I think you just found a bug!.  It is not common to use closed loop with the speed lockout turned off so it probably hasnt been noticed before but as you have found when you turn the speed lockout off, the idle control goes into constant "speed not defined" mode

To get around this you just need to assign a speed source - you dont actually need a speed sensor connected to the ecu or even a DI assigned to speed.  The settings below worked in your map for me.

nqDylQp.png

dA6yJJo.png

Share this post


Link to post
Share on other sites
9 hours ago, StijnDvx said:

Had the same issue on a ttlink so i also think its a bug

Yes as I mentioned above this is a new bug.  It will be fixed in the next release.  For now you just need to assign a speed source - even if you dont have one connected.

 

10 hours ago, Shedley said:

just had same issue ^^

Also not seem to have Idle Derivative Gain Table

There is no Idle derivative table for E-throttle.

7aKOUqM.png

Share this post


Link to post
Share on other sites
5 minutes ago, Adamw said:

Yes as I mentioned above this is a new bug.  It will be fixed in the next release.  For now you just need to assign a speed source - even if you dont have one connected.

 

There is no Idle derivative table for E-throttle.

7aKOUqM.png

Don't understand this, my manual says something different, that's why i'm a bit confused

idle derevative.jpg

Share this post


Link to post
Share on other sites
3 minutes ago, Shedley said:

Don't understand this, my manual says something different, that's why i'm a bit confused

Sorry, you are right.  Im using a newer version of PC Link.  That must have been a mistake that has since been fixed.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×