Jump to content
Benwood

Celica st205 G4+ injector issue

Recommended Posts

Hi folks,

Having an issue with my st205 pnp setup.

Got the car running on it fine with a set of blitz 850cc injectors and walbro 255 pump, set base timing and had it idling ok. Stopped it to check fluids etc but when we went to run it again the injectors seemed to be stuck open. 

1,2 and 3 cyl plugs where soaked and even with injection mode set to off it was filling the cylinders with fuel. 

Anyone got Any ideas on This? 

Got good continuity between injector plugs and ecu for the trigger wire. 

I have pulled the fuel pump relay and cranked her over whilst logging the data which is attached below.  Had the injectors out and tested on the bench, all seem to work fine and have now been refitted. 

Log 2018-04-10 9;51;39 pm.llg

Toyota Celica ST205 G4+ Xtreme Plugin s553tcv.pclr

Share this post


Link to post
Share on other sites

I dont see anything obvious in your log or map.  It is pretty unlikely that there is an injector drive problem but to confirm you can do a quick test to see if the ECU is holding the injector open.  Unplug an injector, put a test light or voltmeter across the two injector wires.  With key on, engine off it should read close to 0V or a test light will not be lit.  If you then turn on the injector test function your test light should flash, (or voltmeter should show some voltage).

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...