Jump to content
Sign in to follow this  
rocklizzard91

Air temp sensor location

Recommended Posts

Hey everyone! I've got a Link G4+ plug-and-play ECU on my version 9 STI and I'm looking to put an air temp sensor in the manifold so that my ECU can compensate for the cooler air temps my water injection will bring.

I have a Bosch open element sensor that I would like to use and I'm uncertain of placement. I'm thinking that I would either like to put it in the floor of the plenum sticking straight up so that air flows across it coming out of the throttle body, but I need to make sure that I have space underneath the manifold for me to put the sensor there. I would also need to have a bung welded on for that location which will cut down my clearance a little bit as well.

My alternate location is in one of the runners which seems like it would always have good airflow across it and it's closer to the port so it should be a more accurate air temperature. However, I'm worried that it might cause turbulence which may affect fueling to that cylinder. Do you guys have any thoughts or comments? I don't daily drive the car but I would like to have the ability to if needed, so I would like to avoid difficult heat soaked hot starts, which I do think the plastic sensor will help cut down on versus the metal GM sensor.

I have included pictures have both my proposed locations

https://drive.google.com/file/d/1pQMTF77ts3Lf9lIoy9a4Jie4tHulovN5/view?usp=drivesdk[/img]

https://drive.google.com/file/d/1opsO1nXJpXZ7-jxnvbgBy-jlz_Osoip5/view?usp=drivesdk[/img]

 

I'm open to any input! Thanks!

Share this post


Link to post
Share on other sites

I've got the IAT sensor mounted in my intercooler pipe just before the throttle, but have recently purchased some of the T1 Race fast response sensors (basically glass bead NTC thermistor potted to a 1/16npt housing) https://www.t1racedevelopment.com/category/universal-parts/electronics/sensors/temp-sensors/t1-fast-at.html

I'll be installing a T1 sensor into the TGV delete's right near the port face.

With both installed I'll be able to see the difference between the two and then decide which will be best to use when I switch my setup over to modelled fuel mode.  I'm expecting if the T1 sensor works well I'll be able to have my charge temp table mostly biased towards IAT

Share this post


Link to post
Share on other sites

Oh man, that's very cool! That's an spendy little sensor, but I like the experiment you're going to do! Any idea when you're going to get around to doing that? I would certainly like to see the results!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×