Jump to content
Geo

Fault codes Errors

Recommended Posts

Hello. I am getting these errors on my 1990 eagle talon/mitsibishi eclipse on my GR+ VR4 ECU and I can not figure out what they are for. The position are off and I dont know if they are suppose to be on or what they connect to? 

[6:47:24 PM] ECU Fault Code 31: An Volt 8 above Error High value
[6:47:11 PM] ECU Fault Code 28: An Volt 7 above Error High value
[6:47:00 PM] ECU Fault Code 26: An Volt 6 below Error Low value
[6:46:59 PM] ECU Fault Code 20: An Volt 4 below Error Low value
 

Share this post


Link to post
Share on other sites

They may be historic.  If you clear the fault codes to they come back?  If those analog inputs are turned off then they shouldnt generate a fault as far as I remember.

Share this post


Link to post
Share on other sites

Thanks Adam. That worked.  I got another question. My fan setup on my car doesnt seem to work so I was thinking could I wire out my fan switch that is in my rad to my Ac clutch output and change it to fan on software? The switch is a thermo switch and it has a relay. Could i just wire it straight to ECU to AC clutch relay output and do I have to use a relay? I attached a pic of my fan switch. It is 2 wire ground and 12v

fan switch.jpg

Share this post


Link to post
Share on other sites

Yes, you can use Aux 4 (pin #65) which was originally the AC Clutch output to switch your fan relay.  The aux output will send out a ground to turn on the fan so you will have to confirm the relay is wired to work that way.  Also be aware the relay coil power needs to switch off with the ignition switch.

Share this post


Link to post
Share on other sites

Hi Adam. thanks for your expertise. 

My Car used to have a ISC stepper motor that connected to throttle body. I now have a hypertune  throttle body and I needed external IAC idle air control valve. I have a Bosch 3 wire and I used my exiting wire harness, 1 12v wire and 2 other wires I used positions where my stepper motor said aux 5,6 on ecu. I was wondering do I configure the IAC as a Solenoid or a stepper motor on PC link? I attached picture of IAC.

Thanks

bosch.jpg

Share this post


Link to post
Share on other sites

It will need to be set as solenoid. But you will have to use Aux 1 for the ISC Slave function.

You will likely have to move the function on Aux 1 to one of the other free drives.

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×