Jump to content
jetape

CAN Setup "Mode"

Recommended Posts

I see a few vehicles in the Mode dropdown under CAN Setup and wondering what that is exactly.

Is that a pre-configured list of CAN messages that will be broadcast from the ecu for the selected vehicle?

Share this post


Link to post
Share on other sites
On 6/23/2018 at 9:50 AM, jetape said:

I see a few vehicles in the Mode dropdown under CAN Setup and wondering what that is exactly.

Is that a pre-configured list of CAN messages that will be broadcast from the ecu for the selected vehicle?

Yes, this is mostly for our Plugin ECU's but can also be used if you are using a wire-in ECU in one of those particular models.  Theses preconfigured streams are designed to keep all the common OEM functionality working.  In Modern cars the ecu will receive data like Cruise control buttons, A/C request, wheel speeds and stuff like that over CAN, and the ECU will transmit data to control or switch on dashboard instruments, fans, power steering, etc.

Share this post


Link to post
Share on other sites
20 hours ago, Adamw said:

Yes, this is mostly for our Plugin ECU's but can also be used if you are using a wire-in ECU in one of those particular models.  Theses preconfigured streams are designed to keep all the common OEM functionality working.  In Modern cars the ecu will receive data like Cruise control buttons, A/C request, wheel speeds and stuff like that over CAN, and the ECU will transmit data to control or switch on dashboard instruments, fans, power steering, etc.

Interesting and weird at the same time.  I'm tuning a seadoo 4tec motor, if I pick "SeaDoo 4Tec" from the CAN Mode list and start it up no RPM makes it to the cluster, just reads 0.  If I disable it then the cluster works fine.

Is it possible to get info on what data is behind that setting or are they proprietary.

Share this post


Link to post
Share on other sites
7 hours ago, Adamw said:

Is this a Riva plug-in or a wire in ECU?  If the cluster works then it must be getting CAN from somewhere already?

 

Yeah it's the blue riva plug-in.

Strange, I don't see any CAN Bus details anywhere, unless they have them hidden in the firmware not visible to pclink and setting the mode in pclink creates a conflict.

Share this post


Link to post
Share on other sites
6 hours ago, Adamw said:

Were you looking at CAN 2?  CAN2 is connected to the Ski network, CAN 1 I think is one of the expansion connectors.  Here's how my Riva basemap looks:

RA5rDcY.png

Oh boy don't I look silly now  :)  I was looking at CAN 1 and setting that one so it was creating a conflict with already set CAN 2.  Thanks

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×