Jump to content
jetape

GP RPM Limit axis max value issue

Recommended Posts

I want to setup rpm limit based on exhaust temperature.  I have temp sensor hooked up to AN T3, if I use that as the Y axis it says it can't be above 151 and I need it to go up to about 220-230.

 

 

 

gprpmlimit1.PNG

Share this post


Link to post
Share on other sites

The GP temp parameter is only 8 bits so it is set up to only cover a range -50-150Dec C as you have found.  You can change the Temp 3 function to "RTD EGT", which will allow higher numbers.  There is a bug in the calibration table for RTD EGT sensors at present but if you give more detail about your sensor calibration I will help you with a set up example.

u26RM75.png

Share this post


Link to post
Share on other sites
6 hours ago, Adamw said:

The GP temp parameter is only 8 bits so it is set up to only cover a range -50-150Dec C as you have found.  You can change the Temp 3 function to "RTD EGT", which will allow higher numbers.  There is a bug in the calibration table for RTD EGT sensors at present but if you give more detail about your sensor calibration I will help you with a set up example.

 

 

Oh, when I said 220-230 I was referring to F so that's about 110C.  My options are set to F for temperature and that's what I see in all other tables.

As far as the sensor it's a stock seadoo sensor so I picked "SeaDoo NTC" from sensor type.  It seems to be registering correctly in the logs and I see values up to 170F.

Share this post


Link to post
Share on other sites

Ok, sorry. I havent tried this yet but I think you will have to hit the U key to change the units back to metric (°C), set up your table axis in C, then when you change units back to °F it should be displayed correctly.  Obviously it shouldnt need to be done this way but I do know there have been some problems reported when setting up table axis in non-native units and engineering has recently done some work on axis unit conversions.

Share this post


Link to post
Share on other sites
35 minutes ago, Adamw said:

Ok, sorry. I havent tried this yet but I think you will have to hit the U key to change the units back to metric (°C), set up your table axis in C, then when you change units back to °F it should be displayed correctly.  Obviously it shouldnt need to be done this way but I do know there have been some problems reported when setting up table axis in non-native units and engineering has recently done some work on axis unit conversions.

Nice that worked.

Quick confirmation, this is how I made the table look.  I want RPM to be limited to 3000 RPM if the temp reaches 110C ..does this look right?

gplimit1.PNG

Share this post


Link to post
Share on other sites

Got to be careful with this trick, it all looked good in PCLink, I could swap back and forth between units and the table looked correct.  After connecting to ECU and writing the new map on ECU it got converted and the C values from the table got turned into F values in the ECU so 110C become 110F.  I had to redo the trick while connected to the ECU and then it saved in the ECU correctly.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×