Jump to content
Sign in to follow this  
edzilla

1991 R32 GTR - No spark, ECU disconnects

Recommended Posts

Hello Everyone,

Hoping to get some help with a 1991 R32 GT-R on a Link G4+ Plugin ECU. I did a search for these issues and tried all the suggestions I found but have not had any luck.

This is a brand new install. The car is a stock 1991 R32 GTR. 

First thing I noticed after installing the ECU was that it disconnects while cranking. Battery was low initially during cranking so I put a charger on it for the remainder of these tests. Even with the charger the ECU would disconnect. We decided to use a power probe to manually apply 12V power to pin 49, bypassing the ECCS relay for now. We did verify 45 had power at key-on. This finally allowed the ECU to stay online while cranking. We also tried dip switches in both positions, R34 and Other. Neither make a difference. The J1 jumper is removed. I reseated the ECU connector a few times, double checking to make sure the sides were not caught on anything or popping up, 10mm bolt is very tight/snug. I don't believe there to be an issue with the ECCS relay system. I've owned the car for the last 2 years and it's never given me a problem, so I'm still a bit confused as to why I need to manually feed it power to stay alive during cranking.

Second issue was now I was not getting any engine speed or spark while cranking. I am using the GTR basemap, I did not go through the Test ECCS Sync procedure. Widest slot was set to 24 per the basemap. I was never able to get spark while cranking so I wasn't able to run through the base timing setup either. I've tried trigger offset values of 0, -82, and -80 without any luck. I am able to use the ignition test function to trigger coil 1 and visually verify spark. While cranking, RPM stays at 0. I setup a new parameters window to watch Trig 1 and Trig 2 Signal, they always stay on 'NO'. I was only able to see this towards the end when we used the power probe to keep the ECU from disconnecting.

TPS calibrated fine. I am using the on-board map sensor.

The only thing I can think of is that the car came with an "Ultra" brand turbo timer. Its never seemed to work and I tried the above tests with the timer on and off. There are no sensors that have been wired in. I also tried unplugging both MAF sensors with no change.

After giving up, I swapped the PCB's and put he stock ECU back in place. The engine fired up on the first crank. 

It was difficult to keep the ECU online while doing these tests so unfortunately I don't have any logs to share. 

Any suggestions would be greatly appreciated.

Thanks,

 Ed

Share this post


Link to post
Share on other sites

Try putting a temporary ground on to pin 16, This is the control pin for the ECCS relay and when at ground the relay should stay on.

Then make sure the voltage at  pins 49 and 59 stay at battery voltage at all times.

Also check you have power to the CAS during crank should match battery voltage

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×