Jump to content
TechDave

[UPDATE] PCLink 5.6.6.3564 (on hold)

Recommended Posts

On 10/23/2018 at 10:28 PM, MeikVr6 said:

Hello

When come your new final Update? Have your update a better PID Boost controller?

BR

Meik

 

 

I am curious to know what you would change?

The only thing that springs to mind for me would be the option to keep D active during stage 3 and perhaps give P, I, and D tables rather than single values.

Share this post


Link to post
Share on other sites

We are aware there can be improvements made to boost control but it is a major undertaking so is not likely to be done for some time.

Share this post


Link to post
Share on other sites

I have just downloaded 5.6.5.3388b.

When I go to add to the Parameters List on the logging page I click on a folder and it adds every parameter in it rather than letting me choose what I want.

Share this post


Link to post
Share on other sites
47 minutes ago, Rob W said:

I have just downloaded 5.6.5.3388b.

When I go to add to the Parameters List on the logging page I click on a folder and it adds every parameter in it rather than letting me choose what I want.

don't double click on the folder, it is a feature that adds all parameters under that folder, just click once to expand , then select the one you want.

Share this post


Link to post
Share on other sites
On 8/15/2018 at 11:40 AM, TechDave said:

 

G4+ Firmware Version 5.6.6.3557 – 15/08/2018

Solenoid Idle Speed Control now shows status correctly.

  • Stepper Idle Speed Control now stops at the Minimum Clamp.

Post any issues you have here, rather than starting new threads, or my favourite, at the bottom of a completely unrelated thread.

Hi,

I am still seeing an invalid status for the Idle Status (in 5.6.6).  It shows as a static name (usually crank %DC) even when it is active as per the following screenshot.  The only way I can tell if ignition idle is active is by monitoring the Ignition Idle Value.  Is this me or still a bug? 

I am not using an idle valve only ignition idle control, which might be the reason?  Even so, I would still expect the status to display something like "Inc. RPM" or "Dec. RPM" the same as when idle status is working with ethrottle for instance.

Thanks,

 Richard.

 

Clipboard01.jpg

Share this post


Link to post
Share on other sites

Hi Richard, This would be normal to me as you are not using the Idle control mode that the status is linked to it is expecting there to be an output for ISC solenoid of stepper. 

 

 

Share this post


Link to post
Share on other sites
30 minutes ago, Simon said:

Hi Richard, This would be normal to me as you are not using the Idle control mode that the status is linked to it is expecting there to be an output for ISC solenoid of stepper. 

 

 

ok fair enough, but is there any way you can add the "Ignition idle control" value to the Idle speed section of the Aux Functions Runtime Value?  That would help a lot for tuning idle.

Or alternatively show the idle ignition value under the ignition tab somewhere and also not show Ign Table 1 as active when it isn't...

TIA.

Share this post


Link to post
Share on other sites

I'm not sure why you'd buy a different ecu with this lack of update being the reason...  doesn't make any sense to me.  I've got 4x G4+ ECU's across my cars and none have any issues in everyday operation that I'm desperate for an update.

Share this post


Link to post
Share on other sites

I'm starting to get really anoid of the total silence from the Link team. it would be decent if youcould give me some hint when in time you have the new release planned?

Just give me a hint and I consider if a change of brand is nescessary because this has taken far to long time to fix. Other brands seems to be more "on their toes" so I'm not going to waste time waiting for something that never going to happens and promised when purchasing the product.

/Hans

Share this post


Link to post
Share on other sites
6 hours ago, a6_quattro said:

I'm starting to get really anoid of the total silence from the Link team. it would be decent if youcould give me some hint when in time you have the new release planned?

Just give me a hint and I consider if a change of brand is nescessary because this has taken far to long time to fix. Other brands seems to be more "on their toes" so I'm not going to waste time waiting for something that never going to happens and promised when purchasing the product.

/Hans

Ive had nothing but good experience with all the tech guys. As for firmware updates the last one before it was pulled I had no issues with it. In regards to the closed loop e throttle problem you have had did you ever end up answering Adam in his last post?

 

Share this post


Link to post
Share on other sites
4 minutes ago, StijnDvx said:

can someone please give a eta ? 

I tested what I understood to be the last few fixes for 5.6.6 on Friday so I can only say it is getting close, but I dont have an ETA.  They will still need to add all the different language translations and stuff in and then check it installs and works correctly for everybody from there before final public release.

If there is some specific fix that you are waiting on, let me know and I will give you a test version.

Share this post


Link to post
Share on other sites
2 hours ago, Adamw said:

I tested what I understood to be the last few fixes for 5.6.6 on Friday so I can only say it is getting close, but I dont have an ETA.  They will still need to add all the different language translations and stuff in and then check it installs and works correctly for everybody from there before final public release.

If there is some specific fix that you are waiting on, let me know and I will give you a test version.

i want to disable the input speed on the idle with the dbw that was an issue 

Share this post


Link to post
Share on other sites

Can someone send me a drop box link or similar to the latest un-released PC Link 5.6.6 Please.

My tuner has updated the firmware on my ECU and i'm now unable to connect with the older version obviously. He had to update it to solve the fuel pump speed control bug.

He's a busy man and getting it from him will take time ^_^.

Too big to email to me no doubt.

Regards,

 

Share this post


Link to post
Share on other sites
7 hours ago, StijnDvx said:

i want to disable the input speed on the idle with the dbw that was an issue 

Have had that issu as well, put iff you set something as a wheels speed, it stops happening 

5 hours ago, Kitto said:

Can someone send me a drop box link or similar to the latest un-released PC Link 5.6.6 Please.

My tuner has updated the firmware on my ECU and i'm now unable to connect with the older version obviously. He had to update it to solve the fuel pump speed control bug.

He's a busy man and getting it from him will take time ^_^.

Too big to email to me no doubt.

Regards,

 

You can also reinstall older firmware, in the update firmware tab, choose a older firmware, and install it

Share this post


Link to post
Share on other sites
8 hours ago, Shedley said:

You can also reinstall older firmware, in the update firmware tab, choose a older firmware, and install it

I don't want to install the older firmware as it has a fuel pump speed control issue that the new 5.6.6 fixed. There was also an update to live lambda map tables of some description which my tuner wants my vehicle to use.

All i need is PC Link.

Share this post


Link to post
Share on other sites

If I use the PClink 5.6.5 software and try to connect to an ecu with the 5.6.6 firmware, will I be locked out with the possibility of loosing my current .pcl file?

 

I had my car tuned around the time the 5.6.6 software was released and pretty sure my tuner updated the firmware before tuning. Car runs great, but I wanted to fiddle with some of the launch control settings before an event, but just want to make sure I dont get locked out by trying to do so.

Share this post


Link to post
Share on other sites
2 minutes ago, DSORDA said:

If I use the PClink 5.6.5 software and try to connect to an ecu with the 5.6.6 firmware, will I be locked out with the possibility of loosing my current .pcl file?

 

I had my car tuned around the time the 5.6.6 software was released and pretty sure my tuner updated the firmware before tuning. Car runs great, but I wanted to fiddle with some of the launch control settings before an event, but just want to make sure I dont get locked out by trying to do so.

No, nothing bad can happen.  If the ecu has 5.6.6 firmware it just won’t connect to 5.6.5. If you can’t connect send me a pm and I will give you the latest test release to use.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...