Jump to content
Shamwow

Nissan VG30 Optical Trigger Scope Question

Recommended Posts

Hi,

I am configuring my new Link Xtreme G4 on my 1984 Nissan 300ZX with VG33ET.   I have wired the ECU and setup the triggers and am evaluating them using the Trigger Scope function.  I am preparing to start the car.

This engine has an optical sensor in the distributor body (cam driven) which reads crank and cam signals.   I have removed the stock optical wheel and fitted a 12-1 wheel from diyautotune.com (pic here https://www.diyautotune.com/product/54-mm-optical-trigger-wheel-for-nissan-l28et-or-vg30e/).  As you can see it has one cam sync slot.

When cranking, The runtime values show an appropriate crank RPM (~350-400), and both trigger 1 and 2 are green. No trigger 1 errors accumulate.  So that seems good.

However, the cam trigger doesnt look very good to me on the scope.  As you can see from the blue trace below, there is one big trigger event, but lots of little jitters as well.  Is this something I should be worried about?  So far i tried changing the filter level from 1, to 2, to 3, but no difference on the scope.

Thanks

Mike

trigger log cam filter 2.jpg

Share this post


Link to post
Share on other sites

Trigger 2 is not happy at all, it is not going to run like that.  You should just see a single “tooth”.

 Do you already have the pull up turned on?  If so I would be suspicious of a bad connection or the cas sensor is faulty. 

Share this post


Link to post
Share on other sites

The nissan optical disc come in several diameters. Make sure it's the same as the you pulled out.

Put the stock one back in just for a trigger scope, will rule out a cas issue. 

Share this post


Link to post
Share on other sites

Hey thanks for the replies!

 

I checked disc diameter and they were the same between the OEM 360 nissan disc and the diyautotune disc.  I did notice that the DIYautotunedisc had some slight rub marks on it.  The disc is thicker and its flatness isnt very good, lots of runout.  Seems like it could cause issues.

I replaced the DIYautotune 12-1 disc with the OEM nissan disc and scoped the trigger signals.  They look clean to me. Cam and Crank are reversed on the OEM disc, so if I proceed with this disc i would need to swap my wiring pins such that the 360 (blue) trace is on trigger 1, correct?

any reason not to proceed with the OEM disc? This engine will rev to 7000rpm.  Or Should I try to replace or fix the DIYautotune disc?

 

 

trigger log with optical disc.jpg

trigger log with optical disc zoom 2.jpg

Share this post


Link to post
Share on other sites

One follow up question that may be related. 

The vg30 cas is inside the mechanical distributor housing.  So to set base timing i locked it at 0deg in the software (calibrate under triggers section) and rotate the housing to set timing at the crank pulley.

I ended up needing to type in an ignition offset of -50degrees in order to get the timing close enough to be able to mechanically adjust it. 

-50 deg seemed like a lot to me. Anything to worry about there? Is this typical practice?

Mike

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...