Jump to content
boXXer

HELP required setting up Launch control on my Fury

Recommended Posts

Hi guys, so i have fitted a inline brake switch from my hydraulic handbrake and wired it on Di2 ans it switches the launch control program on and off no problem at all (well the status changes anyway).

The only thing is, it doesnt do anything at all when enabled. I set the revs to 1500RPM for testing, but it just revs straight past. Anyone got some base settings i can try or i have forgotten to change a setting in the ECU.

Have attached some pics of the ecu status and my settings.

Thanks in advance

 

IMG_3763-30-09-18-06-22.jpeg

IMG_3761-30-09-18-06-22.jpeg

Share this post


Link to post
Share on other sites
3 hours ago, boXXer said:

Ah ok. What does that do? I know there’s a help file but I’m no ok my laptop. 

This is where you set if you want the launch control to cut ignition or fuel.

 

2 hours ago, boXXer said:

also, is the launch ignition trim a - (minus) figure or not?

It depends on the other setting above "Ign retard mode".  You currently have it set at "degrees", so an ign trim of -10 will retard the timing by 10 degs (taken off your current ign angle).  +10 would advance the timing.

acc0EdI.png

Share this post


Link to post
Share on other sites

Every car will be different depending on what you want to achieve and how all the other factors are set up.  I would start from a conservative point and increase from there.  start at around +10 abs.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...