Jump to content
grisom

Ford Ecoboost GDI Pump calibration

Recommended Posts

Hello. I am new here. Purchase Force GDI for my Ford Ecoboost engine. 4 cyl DI. It has 60-2 crank trigger wheel and VVT camshaft with 4 teeth. There is no trigger preset for this engine. So will it work with my ECU? I assume I need to chose multi tooth/missing. But what about cam trigger? Cam Level?

Screen Shot 2018-10-07 at 20.53.22.png

Share this post


Link to post
Share on other sites

There is a very good chance this will match the Holden V6 Ecotec Series II trigger.

To be sure we would need a scope trace showing the CAM and crank signals together.

Share this post


Link to post
Share on other sites

Hello. Today was a good day as finally I have calibrated my GDI pump on Ford EcoBoost engine with Link Force GDI. So I reached results from this:

Screenshot_2018_12_20_at_17_58_28_800.jpi.gif

 

To this :

Screenshot_2018_12_20_at_18_00_30_800.jpi.gif

 

The major thing that was slowing me down is that GDI pump settings in PC link isn't working in real time. (I didi try 5.6.5 and 5.6.6 firmwares). So first you need to change values then store, switch ignition off-on and then changes will be applied. But still I have some questions regardless of my results:

 

1. Max. Volume Per Lobe

Where this can not be measured, this number can be tuned in real time. Refer to GDI Pump Control Tuning.

Cant find in help file where it can be measured. 

 

2. GDI pump control (%) log parameter is always highlighted with red and valued -6% at idle and -10% at high revs. Is it a normal behaviour? 

Log file attached. Thanks for help!!

 

Work GDI.llg

Share this post


Link to post
Share on other sites

Hi Grimson,

Unfortunately I got to your log a bit too late today and all the clever people have left the building already with just me left (Christmas holidays start today for most companies in NZ).  Im lacking in GDI experience so arent going to be able to answer all of your query.

 

13 hours ago, grisom said:

1. Max. Volume Per Lobe

Where this can not be measured, this number can be tuned in real time. Refer to GDI Pump Control Tuning.

Cant find in help file where it can be measured. 

Usually is it done by measuring the pump piston diameter and stroke,  I dont know what strategy is used for "tuning" this setting without physical measurement however if that is what you are asking.

 

13 hours ago, grisom said:

2. GDI pump control (%) log parameter is always highlighted with red and valued -6% at idle and -10% at high revs. Is it a normal behaviour? 

I have a few GDI logs on my PC and from what I can see this is normal.  It looks like it is a +ve number when rail pressure is below target and -ve when the rail pressure is higher than target.  You can stop it from flashing red or orange by going to the parameters screen and adjusting the "Low soft warning value" and "low hard warning value".

Share this post


Link to post
Share on other sites

Adamw,

Thanks for reply. I know I need to measure GDI pump Max volume per lobe but the pump itself is a one solid construction, so there is no chance to measure it if only not to brake it. I was hope that it can be measured or set up this parameter experiment way.

Share this post


Link to post
Share on other sites

Hi guys si the timing if the GDI pump is taking place via the cam shaft trigger wheel? Are you obtaining a constant fuel rail pressure? My project is a 2.3 ecoboost 4 lobe engine.

Share this post


Link to post
Share on other sites

Hello grisom and all the others,

Can you tell me the bore size of the ecoboost's GDI pump? I'm using this type of pump on a different engine for a development project, but this size isn't available anywhere on the web. On the other hand I cannot measure it cause it's a closed geometry.
Or do you have settings for the high pressure pump in the Link ECU? It will really helpful for me.

Thanks 

Denes FARKAS

Share this post


Link to post
Share on other sites

Hi 

It would be great if you can share you results, regarding high pressure pump, trigger pattern and injector charakterisation. 

Thanks. 

Share this post


Link to post
Share on other sites

Trigger Pattern is the Holden Alloytec III
Offset -213
I can't remember which cam we synced off, I think intake, exhaust wouldn't sync, something to do with pull up voltages.
There are a few flavours of ecoboost cam lobe profile, 3 and 4 lobe, ours was 3 lobe, cam centerline offset was 140.
I know from destructive measurements that the pump displacement is 0.254cc/lobe
Peak and hold driver 9 and 5.
Didn't get too far into deadtime or pump calibration.

There's a bug in the pump calibration table, you MUST use all 16 columns.
You must power cycle between changes to Pump Cam Centerline.

We had it idling away on an engine frame, tracking fuel pressure nicely.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...