Jump to content
Confused

12v PWM Output

Recommended Posts

Hi all,

I am in the process of fitting a Pierburg CWA50 chargecooler pump (commonly used on BMW X5M). This is speed controllable via PWM, and it expects 12v input on the PWM pin. I'm using Aux 6 on a G4+ Extreme.

Am I right in believing that the PWM outputs can only switch to ground (otherwise they are floating) - which appears to be the opposite of what I need here?

I'm happy to build a small circuit (or buy something) to convert this Negative-switched PWM signal into a positive-switched PWM signal. I can (to get it up and running) feed it 12v through a 1k resistor, which will set the pump at full speed, but I would like to be able to control it via my shiny ECU.

Cheers in advance!

Share this post


Link to post
Share on other sites

Aux 5 to 8 can high side drive to turn the pump on or off, although if you want to use a variable speed, and are using the Aux out as a GP PWM, 0% duty cycle will be 12 Volts and so turn your pump on and 100% duty cycle will output 0V and turn the pump off, just set your PWM table up with the temperature versus duty cycle axis upside down.  

HTH,

 Richard.

 

Share this post


Link to post
Share on other sites

The aux outputs have a pull up resistor to 12V, so they are 12V when "off" and ground when on.  These can be directly connected to an aux out with nothing extra.  As Richard says though, the logic may be inverted ie 0% = max flow 100% = min flow, I have set one up before but cant remember if they work that way or not.  

What is important though is they need a 3ms "wake up" pulse, so to do this you have a cell in one corner of your PWM table that it will always pass through during at startup (say 500RPM), then you can drop back to normal numbers after that.  Use 150Hz frequency and 50%DC to give the 3ms.

Read this for the min/max DC:  https://www.tecomotive.com/download/PWMinfo_EN.pdf

Share this post


Link to post
Share on other sites

Thanks Richard and Adam.

I spent a while looking through the manual but obviously didn't realise that at 0% duty it's actually outputting 12v, I thought it was floating.

That makes life a lot easier, and I'll invert the values in the table I've already started to put together.

Cheers for the quick responses!

Garry

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...