Jump to content
Simon Kribstock

Subaru V5-6 IAT

Recommended Posts

26 minutes ago, Simon Kribstock said:

I have a v5 STi with OEM IAT. I bought a GM IAT and installed it just before the throttle body. Should I use the expansion connector or should I snip the OEM IAT and wire it to the GM IAT? 

You have both options, you can just use the oem wires and change calibration in the ecu. That's what I should do

Share this post


Link to post
Share on other sites

Would the OEM IAT be routed to pin B136-19 on the main header? The manual says that pin is AN Temp 3 (V1.1 PCB only),which to me, suggests the OEM IAT but I have no way to confirm. Nothing is configured for AN Temp 3 on PCLink as this input is also on the expansion connector.

Share this post


Link to post
Share on other sites

As far as our notes go, they say the V5/6 cars never had a factory fitted sensor so I dont know which pin your one would be connected to.  AN Temp 3 is available on both the expansion connector and B136-19, however as far as I know B136-19 was only chosen as it is normally just an unused spare pin.  You may be able to work out what pin your sensor is connected to by looking at wire colours.

Share this post


Link to post
Share on other sites
3 hours ago, Adamw said:

In the V7-9 and the V10 there was an IAT device in the MAF, but not the V5-6 as far as I know.

My IAT sensor is separate from the MAF. I have an RA Limited  STi; maybe that’s the difference? 

Share this post


Link to post
Share on other sites

I suspect as you mentioned that B136 pin 19 is the Stock IAT. Will soon know if you turn the function to IAT and see if you get a reading, If no connection the input will go to 5Volts and throw an error. 

Share this post


Link to post
Share on other sites

I set AN temp 3 to IAT and sure enough it works. Matches ECT +/- 2 degrees. With that said, I’ll wire my GM IAT, mounted just prior to the TB, using the OEM IAT circuitry; unless otherwise advised.

I’m curious about AN temp 3 on my expansion connector now. How will that input work?

Share this post


Link to post
Share on other sites
Just now, Simon Kribstock said:

I’m curious about AN temp 3 on my expansion connector now. How will that input work?

It wont, the same input is available on the Exp connector and B136-19, so only one can be used.  You still have AN Temp 2 on the Exp that you can use though.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...