Jump to content
Wuppet

Trouble starting

Recommended Posts

Folks,  Hoping you can assist - cannot get this mutha to run

496 cube mopar with thunder g4+ ecu (engine was running with another ecu, but not tuned)

- Fast dual sync distributor as trigger source - both hall sensors

- Fast 36 lb injectors x 8 into single plane manifold runners with square bore style throttle body

-fuel pressure approx. 55psi

-MSD 6al ignitor and msd coil

Have static timing on TDC and Trigger calibration shows exactly that - when turning over engine timing light shows 10degrees which would correlate with ignition table

attempted to start with master fuel at 15 - did not even cough -set it to 50and it fired and ran, although was like timing dramatically out, backfiring etc - tried various settings on master fuel belwo about 25 got nothing at 35 barely fired and coughed and backfired etc - would have sworn timing 180 out - have checked that static is correct.

file attached

Any thoughts appreciated

 

1StewsPlymouth.pclr

Share this post


Link to post
Share on other sites

A few quick thoughts,   I think #3 is probably the main issue.

  1. Set dwell edge to rising - MSD is one of the few that needs this.  When you change this your base timing will probably change so you will need to do your trigger cal again.
  2. Your coolant temp was reading 150°C when you saved the map, that would mean no warmup enrichment would be applied which might explain the high master fuel number. 
  3. The rev limiter is also varied with coolant temp so with 150°C coolant temp the engine would be limited to 1000RPM, that probably explains the backfiring etc.
  4. Check the rotor phasing - its posible once it starts and advances that the spark is jumping to another post in the distributor.  Info below how to check this.
  5. Turn off closed loop lambda for now, that will just make things confusing once it is running.
  6. There are some trigger errors showing, maybe not enough to be concerned about yet but keep this in the back of your mind if the other stuff above doesnt help.

TSX694Y.png

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...