Jump to content
George GEP

E46 m3 gauge cluster - shift light

Recommended Posts

Hello does anybody had luck to make e46 m3 shift light work with link or vipec ecu? 

When u select mini in can stuff cluster works but im sure shift light and coolant warmup warning lights need custom can setup

can anybody share ?

 

thanks

Share this post


Link to post
Share on other sites
On 2/9/2019 at 12:38 AM, Adamw said:

File attached.  The RPM limit and most other dash lights are controlled by the virtual auxiliaries.  The map has the RPM limit lights change based on engine temp as they did originally.  Coolant, oil press and CE lights are also on the virtual auxes.

E46 S54 startup with CAN.pclr

where and how are Virtual aux-es linked to CAN or Check light outputs?

how is it setup where to look for logic?

 

thanks

Share this post


Link to post
Share on other sites

The CAN output sends the Virtual Aux status bit.  (it subtracts 1 as ON is represented by the number 2, as a side note I would have thought OFF=0, ON=1 and FAULT=2 would have been more logical)

image.png.fd424dd0e47300a713d58ee28dfce92c.png 

 

image.png.45f45030f2fa45649c5b156ffea08eff.png

image.png.9fa949796dc981d346735f161c5cc3fd.pngimage.png.a85562c25c8d89e2dac7554c468a537e.pngimage.png.06f3e6064c7c10ae7ee39d2c744cebe3.png

 

HTH,

  Richard.

 

Share this post


Link to post
Share on other sites
19 hours ago, Richard Hill said:

(it subtracts 1 as ON is represented by the number 2, as a side note I would have thought OFF=0, ON=1 and FAULT=2 would have been more logical)

Yeah, seems odd initially but I believe this is done as there is an "unassigned" state that better fits as a zero.  So 0 = no function assigned to that aux.  1 = function assigned but result is false.  2 = result is true.  

 

Share this post


Link to post
Share on other sites

Hello, 

I need help, I have assembled a m3 smg box to a manual 330ci, I have coded kms and chassis, paired car equipment and everything well, but I can't get the oil temperature and the rpm LEDs to work. I can code it tb or it would be impossible,? 

Share this post


Link to post
Share on other sites
15 hours ago, Mdh said:

Hello, 


I need help, I have assembled a m3 smg box to a manual 330ci, I have coded kms and chassis, paired car equipment and everything well, but I can't get the oil temperature and the rpm LEDs to work. I can code it tb or it would be impossible,? 

It doesnt sound like this is anything to do with a Link ecu?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...